function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Afzaal HassanAfzaal Hassan 

Process Builder fails when putting an apex code in the comment field

I have a Process Builder where if you add a comment on a "Response" ield in the Case-Comment object then it takes that comment and updates the "New Comment" field in the Case object. This PB was working fine until we hit one scenario. Just a background, this object is basically our way of communicating with out customers and helping them with any developer related issues they may have. In this particular scenario, a customer had a coding related problem, so I tried sending him some apex code. When I pasted the apex code in the "Response" field, the PB failed. It keeps on giving me vague errors "We can't save this record because the "Case Comment: Update Case Fields" process failed. Give your Salesforce admin these details. <b>An unhandled fault has occurred in this flow</b><br>An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information. Error ID: 1557112563-28907 (-630144534). The debug logs doesnt help either. It works for every other comment I am making, but when I put apex code such as this:
<apex:outputPanel rendered="
{!salesInvoice.c2g__Dimension2__r.Logo_URL__c != ''}
<apex:image URL="
it fails! I have tried putting quotes around it, tried converting to a Lightning flow, but nothing works. Can someone please help?
Thank you
AnudeepAnudeep (Salesforce Developers) 
Please contact Salesforce Support and provide the following Error ID for further Investigation

 Error ID: 1557112563-28907 (-630144534)