function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Bryan Leaman 6Bryan Leaman 6 

sfdx Authorize an Org does not complete

Starting yesterday my authorization token became invalid, but when I tried to re-authorize my org the process just hangs at "waiting for localhost" in the browser. I'm using Windows 10 and the latest vscode and the latest sfdx and both were last updated several days ago and had been running fine.

I tried re-authorizing from my personal PC (running linux and month-or-so old versions of vscode and sfdx) and that failed as well. 

I've just uninstalled and re-installed vscode and I still cannot authorize to any of my orgs.
Bryan Leaman 6Bryan Leaman 6
Not sure how this issue affected both my work PC and my slightly older sfdx version on my linux one at the same time, but uninstalling sfdx and re-installing it has resolved the issue.
Bryan Leaman 6Bryan Leaman 6
Just noticed my re-install of sfdx set me back to version 7.81.0, which is 3 months old, but works fine.
Bryan Leaman 6Bryan Leaman 6
Hmm. it just auto-updated to 7.89.2 again and it broke. :(  Looks like I gotta disable automatic updates for a while.