+ Start a Discussion

LWC intellisense not working in vs code

Hi All,

LWC intellisense(autocomplete) is not working in HTML file for lwc in vs code. I have all the salesforce extensions installed. Also, I have tried reinstalling both vs cdoe, CLI and extensions too. Still the same issue.
Have been using this for so long but all of sudden, I was stuck with this yesterday. Can somebody assist here.

AbhishekAbhishek (Salesforce Developers) 

In one of the developer blogs, I have seen this response "They have uninstalled the extensions and installed again, reload my VS code, seems to be working now."

Try this and let me know.
Thanks for your response. I had already tried this multiple times. Not working.
AbhishekAbhishek (Salesforce Developers) 
If you still facing the issue then I would request you to raise a case with the salesforce team.

But If you faced the issue only yesterday means check-in trust.salesforce.com because There are some server issues are happening recently which might be caused you the issue.

weno bakweno bak
I’m extremely impressed with your writing skills and also with the layout on your weblog. Is this a paid theme or did you customize it yourself? Anyway keep up the nice quality writing, it is rare to see a nice blog like this one nowadays. If you like strategy type video game then visit the link and know interesting facts about “All NEW GTA SAN ANDREAS XBOX 360 AND XBOX ONE CHEATS” and click here for “Stellaris System requirements for space simulation.
Aaron Benjamin 1Aaron Benjamin 1
Try disabling SLDS Validator from the Markplace tab. 
Alex Gheorghe ;)Alex Gheorghe ;)
Disabling SLDS validator didn't work. Actually not even a fresh install of the extension pack worked. LWC Intellisense works fine except on expressions within the HTML markup. Any properties or functions added in the JavaScript file do not become available in the HTML template file. How can we get this fixed as it is a huge time saver?
I too am having this issue. I've tried the tips above to no avail. This is also on a completely fresh vscode install.

Are we damned to work without intellisense for HTML expressions, or has anyone encountered the same issue and found a solution?
Nazar PidhirnyiNazar Pidhirnyi
Did someone has any solution?
Ankit Khiwansara 10Ankit Khiwansara 10
Do you have Java Development Kit  installed, with the JAVA_HOME or JDK_HOME environment variable pointing to it? See troubleshooting steps here: https://github.com/forcedotcom/salesforcedx-vscode/issues/2165
Veronin SkadvizVeronin Skadviz
This is great insights