function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Catherine ChukwuCatherine Chukwu 

I can't see the complete sfdx commands on vscode, Authorize an org fails and Apex extension unresponsive

Hello, I'm working on the Quick start: Lightning web component trail and when it comes to setting up vscode with salesforce I've been trying for the past  24 hours to no avail. Things  have and have tried so far
  • JDK 17 from oracle platform(intsalled and unistalled 3 times so far)
  • Salesfore CLI(used the link directly from salesforce and installed/uninstalled twice already
  • set the jdk path in the appropriate field in vscode
  • installed and uninstalled Salesforce extension pac (probably a gazillion times now)
  • updated vscode to latest version/ updated salesforce CLI just to make sure
Despite all these, once i create a dx project and wait a few minutes, i get some dx commands(pic attached), but nothing on create lightning web component or aura components.

Also, for my first try, when i tried to authorize org, it went through and i can see my classes but the other times, authorization goes through but i've stopped seeing anything from my org show up. Also, prettier keeps showing an error.

i've read every related issue so far and it still won't give. Someone suggested checking running extensions and i can see from here that apex is unresponsive, which is why i have installed and uninstalled the salesforce extension pac a gazillion times and it still has the same issue

  • I use windows 10 OS
  • I have had VsCode installed previously as I have been using it for software development prior to salesforce, so I have other extensions and customizations done, Node, Tailwind and whatnot.
Sumit Mishra 47Sumit Mishra 47
check if enivornment variables are set properly . The path should have C:\Program Files\Salesforce CLI\bin or your address to CLI