function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Sarah SSarah S 

email relay not working

hey guys, 
i am setting up email relay in salesforce but its not working.

we have mimecast SMTP server and user is created on that.

I have setup email relay, email domain filter and deliverability setting as suggested in salesforce help docs.

I am doing 'test deliverability' but receiving email from salesforce only '' instead of our SMTP server.
i have checked the email log file and the error is '435 5.7.8 Authentication credentials invalid' but this is fishy because I am entering the correct username and password provided by SMTP server team, infact i asked the SMTP server team to create new user and provide, but it is still the same error.

i am no expert in reading the email log file, and i dont understand that for some row there is no entry in coloum 'M' relay address, why is that, when email relay is enabled it should be for all the email initiated form Salesforce.

what am i missing?

What is wrong? 
SwethaSwetha (Salesforce Developers) 
HI Sarah,
Have you verified if the user name & password fields of the Salesforce setup match that of mimecast SMTP?
Sarah SSarah S
Yes, i mean i cannot check it myself. The smtp/mimecast team has given me. The user name is like and password as passport should be.
Sarah SSarah S
Hi Swetha, if you have ever done this, do you think I am missing something. I mean set up wise or something.
EMail relay settings are like - ip, port, tsl- required verify, enabled smtp Auth, auth type- plain, username and password.
Btissame IBA 12Btissame IBA 12
Hello @sarah S, I am facing the exact same issue here.
have you been able to fix this on your side? if yes how?
Thanks in advance for your help!
Seeng same, any resolution from anyone on the thread?
Solved my issue - policy to bypass MFA required in Mimecast