+ Start a Discussion
NinetaMNinetaM 

Flow error "The delimiter of stage is missing."

I have defined a couple of Stages (Stage 1 and Stage 2) for my flow and embedded a component to show the stages in my 2 flow screens. When I start out on the first screen Stage 1 is correctly highlighted. However when I click Next to move to screen 2 I get this error that I cannot make sense of:

The delimiter of Stage 1 stage is missing.

I have not been able find any information about this cryptic error so I am hoping others have encountered it and know what it means or that SF can shed some light on what this means. 


 
Nathan MarchantNathan Marchant
I have the same problem. I can click next and move the stage along but if the user hits previous i get the same error! Did you solve this? 
NinetaMNinetaM
Unfortunately I have not figured this out nor have I had any other responses.  
Shubham Sehgal 2Shubham Sehgal 2

Hello All, 

I just came across this and wanted to share something that might help. The scenario we have is working as designed. Have a look

https://help.salesforce.com/articleView?id=000350820&language=en_US&mode=1&type=1

https://developer.salesforce.com/docs/atlas.en-us.salesforce_vpm_guide.meta/salesforce_vpm_guide/vpm_designer_screen_components_previous.htm


Thanks

Wealth LineWealth Line
I had this problem and the solution was to make sure that the screen that you hit the previous button at has the checkbox "manually assign variables" checked for the Stage component.
MasahiroYMasahiroY
@wealth line Your solution is right. It fixed the "The delimiter of Stage 1 stage is missing." issue. Thumbs-up!
Rajeev Iyer 9Rajeev Iyer 9
Thank you @Wealth Line - That worked for me as well.
Felipe CarvajalFelipe Carvajal
Thank you @Wealth Line, it works!
Zoran Subotic 10Zoran Subotic 10
@Wealth Line this works, much appreciated