+ Start a Discussion
rajubalajirajubalaji 

how to give permission for unfiled public report folder for non admin users

Hi everyone,

If any one have idea please guide me and explain me on these issue.

My Question was:

How Can i will  Provide unfiled public reports folder access & permission to create new reports for non-admin users.

So,please provide me and give my step by step for better understand.

Thanks Inadvance.

P.Balaji Karthik
Best Answer chosen by rajubalaji
rajubalajirajubalaji
Hi EveryOne,

Go to Setup In Quick Find Box Enter 'Permission Set'.
Create a new permission set. Click on New ---> Give Label --->Give API Name  ----> In License Select 'Salesforce'  ----> Save.
In Apps goto ---> Click On Object Settings  --->  In Find Settings 'Report' and Open it. ---> Edit Tick Available and visible both.
In Find setting type 'System Permissions' ---> Edit it ---> Tick Edit My Reports, Create and Customize Reports, Create Report Folders,
Run Reports, View Reports in Public Folders.
Now Goto Setup In Quick Find Box Enter 'User'. Open the User you want to give permission. Below the user details, there is a related list of permission set edit is 
Select the permission you recently created and Save.
  
I think it will be useful.

All Answers

Devi ChandrikaDevi Chandrika (Salesforce Developers) 
Hi Balaji,
By default unified public reports folder is Accessible by all users except for Community and Portal License Users.If the user is unable to create report in this folder try giving Manage Reports in Public Folders  permission in the 
profile of specific user.
Please refer  below links which might help you further
(https://help.salesforce.com/articleView?type=1&mode=1&id=000327327)
(https://help.salesforce.com/articleView?id=analytics_sharing_permissions.htm&type=5)

Hope this helps you
If this helps kindly mark it as solved so that it may help others in future.

Thanks and Regards
 
rajubalajirajubalaji
Hi Devi Chandrika,

Thanks For reply.But in my scenario is it possible to edit the permission for particular users to create new reports in this folder.

Here i have checked in profile of specific user to give manage report in public report but that option was not there.

Thanks Inadvance.
Devi ChandrikaDevi Chandrika (Salesforce Developers) 
In standard profiles we cannot change some permssions.Only we can clone the profile , create a new profile,give required permssions and assign it to specific user. 
rajubalajirajubalaji
Hi EveryOne,

Go to Setup In Quick Find Box Enter 'Permission Set'.
Create a new permission set. Click on New ---> Give Label --->Give API Name  ----> In License Select 'Salesforce'  ----> Save.
In Apps goto ---> Click On Object Settings  --->  In Find Settings 'Report' and Open it. ---> Edit Tick Available and visible both.
In Find setting type 'System Permissions' ---> Edit it ---> Tick Edit My Reports, Create and Customize Reports, Create Report Folders,
Run Reports, View Reports in Public Folders.
Now Goto Setup In Quick Find Box Enter 'User'. Open the User you want to give permission. Below the user details, there is a related list of permission set edit is 
Select the permission you recently created and Save.
  
I think it will be useful.
This was selected as the best answer
Deepali KulshresthaDeepali Kulshrestha
Hi Balaji,

To permit the non-admin user to access the unfiled public report folder access & permission to create a new report.
You have followed certain steps:-

1:-  Go to Setup In Quick Find Box Enter 'Permission Set'.
2:- Create a new permission set. Click on New ---> Give Label --->Give API Name  ----> In License Select 'Salesforce'  ----> Save.     
3:- In Apps goto ---> Click On Object Settings  --->  In Find Settings 'Report' and Open it. ---> Edit Tick Available and visible both.      
4:- In Find setting type 'System Permissions' ---> Edit it ---> Tick Edit My Reports, Create and Customize Reports, Create Report Folders,
Run Reports, View Reports in Public Folders.     
5:-- Now Goto Setup In Quick Find Box Enter 'User'. Open the User you want to give permission. Below the user details, there is a related list of permission set edit is 
Select the permission you recently created and Save.     
6:-- Done.


I hope you find the above solution helpful. If it does, please mark as Best Answer to help others too.

Thanks and Regards,
Deepali Kulshrestha
www.kdeepali.com