function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Marvin Kramer BERMarvin Kramer BER 

Cannot open Flow / Process deployed as part of an Unlocked Package

Looking for anyone encountering the same behaviour:
  • Via SFDX I created an Unlocked Package containing a few Flows and Processes
  • After installing the Package into a Partial Copy Sandbox for deployment testing, I cannot access the respective Flows and Processes any more.
  • When I click on them in the Flow or Process Builder, I receive the following error messages:
  • On a Process: "Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 1099551912-258214 (2076307982)"
  • On a Flow: The Flow User-added imageIt reads: This page has an errir. You might just need to refresh it. [sourceElementContainer is not defined. It must be defined.] Failing descriptor:{markup//builder_platform_interaction:canvas]
  • Actions that trigger the flows or processes cause the respective flows to fail.
I have absolutely no idea what could cause this issue and hope for any pointers you guys can give me.

The packages were created using sfdx-cli/7.33.2-045d48473e win32-x64 node-v10.15.3 and "sourceApiVersion": "47.0"


Efstathios NtatsiosEfstathios Ntatsios
Hi Marvin, I am having exactly the same problem and so far I was unable to get any helpful reply or insight from anybody. I will be following this and provide any update in case I run into something.
anshul saini 7anshul saini 7
Hi Marvin,I think this error may be because of any related list which exist on same component or page
Marvin Kramer BERMarvin Kramer BER
I had another try with deploying my package yesterday and this time it worked. My only guess is that this might be because of an issue on Salesforce side which got updated with the most recent SFDX CLI Update. I did update to the most recent version via "sfdx update" in the CLI command line Terminal and created a new package version. Upon deploying it worked this time.

So best guess from my side is, that you update your SFDX CLI version to the most recent one.

Efstathios NtatsiosEfstathios Ntatsios

Hello Marvin,
I also updated CLI as you recommended and created a new version of the package, but in my case that did not help. Other than that, did you do anything else differently that could have affected the result (different api versio, different sandbox etc.)? 

BTW I now have an open case with SF about this issue, so if there is any update from their side, I will post it here as well.

Marvin Kramer BERMarvin Kramer BER
Hey Efstathios, I did my successful deployment to a Sandbox which was already running on Spring 20 Release. I haven't tested on a Winter 20 Release Production environment, but if you tried your release in a Winter 20 environment it could be an indicator that this indeed has something to do with an API Version issue. Hope this feedback helps! Marvin
Leanbridge TechnologiesLeanbridge Technologies
This is a continuation from my last article Flow/Process Deployment using Change Sets. In this article, I’m going to discuss how to distribute a Process/Flow using Packages. Packages allow us to distribute the Flows and Processes in any Salesforce organization irrespective of they are connected or not, for example, Developer Edition org and Production Org. Let’s start with a business use case