+ Start a Discussion
TizianoTiziano 

Salesforce IoT

Hi, 
I have enabled Salesforce IoT module. When try to open Contexts configuration display this error: 
"This page isn't available in your org."

Also, when search from setup IoT show only Contexts and Activity Log.

User-added image

Can any one suggest me.
Thanks.
ANUTEJANUTEJ (Salesforce Developers) 
Hi Tiziano,

From the developer guide it seems that you need to have certain permission to be able to use it can you try checking these once.

Article: https://help.salesforce.com/articleView?id=iotx_enable.htm&type=5

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thank you!

Warm regards!
Anutej Poddaturi 
TizianoTiziano
Hi Anutej,
I have Admin Profile with API Enabled and Customize Application enabled. In fact it made me correctly enable the IoT module.
Thanks
ANUTEJANUTEJ (Salesforce Developers) 
Hi Tiziano,

So did it resolve after setting up the the IoT module properly?

Regards,
Anutej Poddaturi
TizianoTiziano
Hi Anutej,
No, the settings I had already enabled.
The problem is still present. I tried to create a new Developer Org too, but it seems that the IoT module is not present.
I don't understand the reason, considering that from the official Salesforce guide it says "Available in: Developer Edition" (without any limitation).

What else can I try?
Thanks,
bhoopal kiranbhoopal kiran
If the first time you enable IoT is during the same session in which you enabled Lightning Experience, the IoT Context page doesn't load.
Repro
1) On an org where Lightning Experience was never enabled, go to Setup > "Get Started" for Lightning Experience on the top left, and enable Lightning Experience.

2) Without logging off, go to Setup > Feature Settings > Salesforce IoT > Get Started, and enable Salesforce IoT.

3) Go to Setup > Feature Settings > Salesforce IoT > Contexts.

4) A blank page will be displayed.
Workaround
Log out, and log back in.