function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Pradeepa P 11Pradeepa P 11 

Lightning component mobile override is not working in salesforce1 app

Dear Community, I need your help,
I have created a lightning component and I wanted to display it in Opportunity new page. So for that, I override the "New" button on Opportunity for Mobile with a lightning component.
When a user clicks on the "New" button in salesforce one app,  After the user picks the record type. It does not going to lightning component page. 
We strongly need a lightning component page as salesforce mobile style. What can we do?
Raj VakatiRaj Vakati
You need to Override the Mobile Override option ... Make sure your component is implement force:apphostable 

User-added image
Pradeepa P 11Pradeepa P 11
I already override the Mobile Override Option and also I used force:apphostable in my lightning component. but still, my lightning page is not rendering.
User-added image
Hello Pradeepa ,

please Check The Skip Record Type Selction CheckBox (See in your Image )Then Make a custom Record Type Selection Logic then pass that record type id in your create record Event component  i think then it should work . For Reference Go to this link,

I think this should help you for sure try that .

Thanx Regards 
Shubham Sharma
Hi Pradeepa,

I too face similar problem. Did you find any workaround for above problem. please let me kow. I have  already checked Mobile overrided option and also checked Record type slection Option too. But stilll it doesn'y redirect me to Custom component

Thanks & Regard,
Varsha Dhage 11Varsha Dhage 11
It is working for me, make sure you are doing following steps:
1. From setup , on stanard button override button , override Lightning experience and Mobile override with your aura component 
2. Also check,  The Skip Record Type Selction CheckBox
3. For recordtype selection use aura component 
4. In aura component , implemet-  lightning:actionOverride,force:appHostable
Please let me know , if this solution worked for you