function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jim Riggio 18Jim Riggio 18 

http:/ refused to connect received after Button calls flow with apex

i have a Detail Page button on OLI that calls this flow.  In Lightning I get a " refused to Connect " error and hangs on the Screen.  Does any one know how to fix this so it will work in Lightning?
Raj VakatiRaj Vakati
Can you please check the debug logs ?? and your URL must be https:/ 
Jim Riggio 18Jim Riggio 18

Hi Raj,   revisting this issue again.  I no longer get the "refused to Connect" error.  I am able to create a Deliverable per our flow.  However, once the New record is created, it does not return back to the OLI.  I get the "Created record" message and it stays on the blank page.

When you said your URL must be, where is do I add this?  in front of the /apex/redirect?  Is it just http:/  Also, if I change URLs, will this affect the Classic operation where it works correctly.

Harish LokuntlaHarish Lokuntla
Hi Jim, did you find any solution for this, i am getting same issue, i have a vf page on account creation when i click on save it should be redirected to account detail page, but i am getting refused to connect. please let me know if you have any solution.
Jim Riggio 18Jim Riggio 18
Hi Harish, I do not get the error anymore, but after I click on button, the system takes some time to complete and then hangs and does not return to the page that it does in Classic. I can imagine some things need to be rebuilt, but have not given it much thought yet as we are stil on Classic. 
praveen murugesanpraveen murugesan
Hello All,

Did any one got the solution for this? Am also getting in my org suddenly, searching the reason & solution.

Praveen Murugesan.
Jim Riggio 18Jim Riggio 18
I have not received any errors like this anymore. Try the process in Incognito window.  we are finally tranistioning to Lightning now so I am hoping that issue won't come up again.
I have recived that message to.
I removed my development mode access then it worked fine.
User-added image
Solution from @VSK works.
Courtney PorterCourtney Porter
Does anyone have an alternative solution for this?  We confirmed we have Development mode unchecked yet still getting the error described above. It sends the envelope but afterward hangs and doesn't return to the same page it kicked off from - getting the refused to connect error.  It works fine in Classic but our users are no longer in Classic.  Any help is greatly appreciated! 
Jim Riggio 18Jim Riggio 18
Hey Courney, I haven't received this message for awhile now.. I tried everything , incognito, emptied cache, development mode.. It just seemed to go away..and haven't seen it since,  try on another computer.  sorry don;t have a concert solution..  good luck
Sahi RepswalSahi Repswal
Hi Guys,
Did anyone find the solution for this ? I am still facing this issue.
Actually, I have a third party application Web tab. On click on that I am calling third party application and there i am authorizing the user. But while i am clicking on that, same message is showing and while I am putting the URL in different tab, it is working for(Asking for access)
Christoph Steiner 13Christoph Steiner 13
hi guys,
first time user here. I'm also getting this issue " refused to connect." after entered Builder from the initial Customize your Site instructions. It's rather perplexing as a first time user in SF. Any help would be appreciated. Note. I've followed everything to the letter so far.
Gaurav Sharma 144Gaurav Sharma 144

Hi @Christoph 

Please allow cookies from your browser then you should be able to load the page in experience builder. Please find below screenshot for reference : 
How to Allow cookies

Ranjan Rozario 1Ranjan Rozario 1

@Sahi Repswal

I'm facing that exact same issue. Could you help on how you fixed the issue ?