function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Apex Data Loader 12.0 CSV File Issue

I am attempting to load products data in SF and am getting the following issue from data loader:

CSV Error:  Invalid CSV FIle Format.  Please select a different file.  Error reading row #789: the number of data columns (19) exceeds the number of columns in the header (17).

If I remove the row in question, the file loads fine. I put the row into a separate file and load that and everything loads fine.  The original file has about 21000 rows.  Has anyone encountered this issue?
I am not sure if you are experincing the same thing as I did, however check the following. When you save your excel spreadsheet it must be saved as a CSV file. When you are asked to point to the source file (Your Spreadsheet) by default the CSV file is not displayed, only the the *.xls files will be listed. Type *.csv to search for all the csv files, you will notice a small B in the bottom right hand side of the icon, this is the file you want.
Hope this helps

I am having exactly the same error. Unfortunately my Data Loader doesn't work even if I remove the line in question, and I have made sure that I am uploading .csv's and not .xls. 


For the record I am using Data Loader 13.0 now, and excel 2007 with vista.


Anyone who can help? 


I got the same error reading row#1(which has the column header names). I am new to salesforce and I just started playing with dataloader to import 10 accounts from a .csv file  on to a temporary custom object.


I tried deleting the first row and I still get the same error, "the number of data columsn(2) exceeds the number of columns in the header(1)".  Can anybody help me? Thank you - Velma.


The error in my case was because the file was saved as a .xls file. I tried to change it by adding .csv to it. It might not work that way. Use save as and select csv from the dropdown list.


Hi Malling


I am expereicing the same problem with a large file (23000).  No matter which lines I remove I still get the same error!

Did you find a solution to this problem?


Thanks in advance




Kay, can you double check your file format?


click save as

select CSV(Comma delimited)(*.csv) and save

Run the load again and see.





Please do make sure that all commas have been removed before saving it as a *.CSV file.




Sanjay Pali 12Sanjay Pali 12

    Please make a change in your record data column. e.g. if you have number field say for “XXX “name with data type “Number (18,0)”.
Then follow below steps:
Right click on that field value in CSV file | Format Cells... | Select “Number” Tab | Category : Scientific | Decimal Place: 18 | Click OK.
Now apply this change in all the records of  that column.

Hope this is helpful.