function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
werewolfwerewolf IDE installs, but none of its options show up in Eclipse

I've been using the IDE since it was called the Apex plugin for Eclipse.  Today I had some trouble on it on Eclipse 3.2, so I got a brand new, clean copy of Eclipse and installed it.  I fired up Eclipse 3.3 and installed the toolkit with its dependency (WST or whatever it was).  Everything seemed to go well.  Eclipse restarted itself.

Upon restart, though, I could see no trace of the IDE.  There was no way to create an Apex (or project.  There is no perspective.  Everything seems to be MIA.  Meanwhile, if I go up to Help->Manage Configuration, the IDE is listed there and seems to think that it is installed properly.

I have tried disabling it, cleaning it out and reinstalling, but to no avail -- upon my second installation (which also appeared to go well), there were no items available upon restart.

What gives here?  Has anyone had this issue before, and if so, how did you fix it?
Hmm, are you sure the perspective is missing?  That seems like the issue.

Its usually under Window -> Open Perspective -> Other . . .
The perspective is missing alright, that's where I went to go find it.  The "Apex" project type is missing too.  Nobody has ever seen this issue but me?
I've seen this, if i remember correctly the problem is that the plugin has dependencies that aren't picked up during install. You have to manually select WST (from the europa tree) it's not automatically picked up as a dependency.
Hooray!  Thank you Simon, that was indeed the issue.  I deleted the elements and reinstalled it, this time choosing the WST components from the Europa Discovery Site, and that fixed the problem.
I had the same problem, and this resolved it. 

Just to clarify, for me under Eclipse ...
1) under Europa Discovery Site
2) open category "Web and JEE Development"
3) Check off "Web Standard Tools (WST)..."
4) install and restart as usual.  I had the ide installed (it wouldn't appear) -- installed WST without disabling, and the restart (suggested as part of any install in Eclipse, it seems) made IDE available.

Nazeer AhamedNazeer Ahamed

I am SFDC admin; Have working with Apex toolkit for one year. I have made this setup earlier well without any issues. But now I tried with IDE, have followed the procedure in the specified link.  Installation is success. But I am not able to see perspective and project in the new menu. I have checked this thread and most of the thread in the forum but it doesn’t help.

I am able to lot of jar related to in Eclipse instable folder C:\eclipse\plugins and there is no folder in work area (D:\SFDC - Work Area\.metadata\.plugins) like ‘’. I hope generally it used to be there. I have checked configuration details as well, that also seems well.

Do you have any idea? Thanks

t anthonyt anthony
You get the same behavior regarding the perspective if you have an older JRE version.

Hi all ,

Can you please help me out for the following issue..

See i have Created a IDE in my Eclipse environment 3.3, now i am able to extract the data through the userid and password but not able to move it to a text file , is there any possibility to achieve this task , please let me know it any...


Seeking your reply soon


thanks ,

Sharma ramanathan 

I had the same problem on WinXP. It turned out I had an older JRE as my default even though I had installed the latest from Sun. I found the solution at this Sun forum. I decided to go with the -vm startup option to eclipse because I had copied the eclipse .exe as a shortcut on my desktop which solved the problem quickly. I'm not sure this is the best as a long term solution because I will have to change my startup option whenever I upgrade the JRE.

Hey Simon,


I have the same problem. I am not a Java developer and just now starting with Salesforce. This is the first time I have installed eclipse and facing the same problem. The list of available software shows IDE but when I go through perspective I can't find it. 


Can you please elaborate on the steps you followed to fix the problem


Thanks in advance