+ Start a Discussion

Apex Data Loader Password Error

I'm having trouble using the Apex Data Loader from the command line.  It works fine thru the GUI.  If I encrypt just my password and run it, I get an "Invalid user name, password, or missing security token" error.  If I encrypt my password and my security token, I get the following error:
2008-08-15 15:46:53,476 INFO  [main] controller.Controller initLog (Controller.java:388) - The log has been initialized
2008-08-15 15:46:53,492 INFO  [main] process.ProcessConfig getBeanFactory (ProcessConfig.java:78) - Loading process configuration from config file: C:\Program Files\salesforce.com\Apex Data Loader 13.0\bin\..\conf\process-conf.xml
2008-08-15 15:46:53,538 INFO  [main] xml.XmlBeanDefinitionReader loadBeanDefinitions (XmlBeanDefinitionReader.java:163) - Loading XML bean definitions from file [C:\Program Files\salesforce.com\Apex Data Loader 13.0\bin\..\conf\process-conf.xml]
2008-08-15 15:46:53,570 INFO  [main] core.CollectionFactory <clinit> (CollectionFactory.java:66) - JDK 1.4+ collections available
2008-08-15 15:46:53,585 INFO  [main] core.CollectionFactory <clinit> (CollectionFactory.java:71) - Commons Collections 3.x available
2008-08-15 15:46:53,648 INFO  [positionExtract] controller.Controller initConfig (Controller.java:343) - The controller config has been initialized
2008-08-15 15:46:53,648 INFO  [positionExtract] process.ProcessRunner run (ProcessRunner.java:102) - Initializing process engine
2008-08-15 15:46:53,663 INFO  [positionExtract] process.ProcessRunner run (ProcessRunner.java:105) - Loading parameters
2008-08-15 15:46:54,663 ERROR [positionExtract] config.Config decryptProperty (Config.java:642) - Error loading parameter: sfdc.password of type: java.lang.String
javax.crypto.BadPaddingException: Given final block not properly padded
 at com.sun.crypto.provider.SunJCE_h.b(DashoA12275)
 at com.sun.crypto.provider.SunJCE_h.b(DashoA12275)
 at com.sun.crypto.provider.DESCipher.engineDoFinal(DashoA12275)
 at javax.crypto.Cipher.doFinal(DashoA12275)
 at com.salesforce.lexiloader.security.EncryptionUtil.decryptString(EncryptionUtil.java:197)
 at com.salesforce.lexiloader.config.Config.decryptProperty(Config.java:636)
 at com.salesforce.lexiloader.config.Config.postLoad(Config.java:588)
 at com.salesforce.lexiloader.config.Config.loadParameterOverrides(Config.java:614)
 at com.salesforce.lexiloader.process.ProcessRunner.run(ProcessRunner.java:106)
 at com.salesforce.lexiloader.process.ProcessRunner.main(ProcessRunner.java:228)
2008-08-15 15:46:54,663 FATAL [positionExtract] process.ProcessRunner run (ProcessRunner.java:156) - Error loading parameter: sfdc.password of type: java.lang.String
It seems to be having a problem with the password but I'm not sure what it's trying to tell me.
I discovered what the problem was.  I did not have the password and security token encrypted properly. 

Message Edited by upsetstomach on 08-18-2008 01:43 PM
Best Answer chosen by Admin (Salesforce Developers) 

add security token to ur password


EX:  passwordsecuritytoken

All Answers

Thank you, this helped.  I was using   encrypt -g <password>,  getting the same error.  Actually read the help for excrypt and chose  encrypt -e  instead, works now.

Hi All,

I donwnloaded Apex loader and installed in my system. but when i log in with user name and password, i get 

an error saying 'Error Logging in to Salesforce, Please check your username and password'. but I use the same 

username and password to login to loging.salesforce.com and i able to login successfully. 


I wonder why in apex loader i get such error.


can someone help here please.




add security token to ur password


EX:  passwordsecuritytoken

This was selected as the best answer
Dung Nguyen 17Dung Nguyen 17
I have the same question with Anjan. Can anyone help us with this????

Cary HowellCary Howell
@Anjan and @Dung Nguyen - Add the securitytoken to the end of your password