function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Errors when uploading data "insufficient access rights on cross-reference id"

I am trying to migrate some data from one SF account to another and after failed effort at using the Excel connector moved on to try the APex Data Loader with Data Export data from Account A. WHen I tried to use the Data Loader to insert the Account data object into Account B I was getting 100% "invalid cross reference id" errors. Upon further inspection of the error file I notice some "insufficient access rights on cross-reference id" errors as well. I googled and came across a thread on here that the problem may be related to OWNERID field. So I removed that field form the mapping and near 100% success. Alas I am still getting the "insufficient access rights on cross-reference id" errors. The other error has vanished.

Does anyone have any idea what could be done to resolve this as no one at SF seems to have a clue?
The error is telling you that you're trying to insert some IDs to reference fields that are invalid.

If you're moving it from one Salesforce account to another, you may have lookup fields that are filled with IDs (OwnerId is one of them).  These IDs are valid in the source org but will not be valid in the destination org.  The solution, as you have partially discovered, is to remove any reference fields, i.e. any fields that contain IDs.

Message Edited by werewolf on 05-01-2008 04:33 PM

I am trying to insert 30 contacts with data loader.


13 are successful.

17 are errors and have the error message, "invalid cross reference id".


Every field has the same data type and is in the same CSV file.  I have asked customer support about this a week ago and they have still not given me an explanation.


Can anybody explain why I am getting this error?

Nevermind, I finally figured it out.  It has something to do with the owner id not being valid even though it is.

I ran into this error recently. There were tons of fields in my object that I had mapped using auto match feature in data loader. There was one field that was a look up field to another object that did not have any data relevant to the value mapped. 


I was migrating Account and there was a custom lookup field to Contact. Since there were no contact data relevant to the value mapped I got this error. Basically I had to remove that map and migrate Account in 2 pases.




I ran into the same error when trying to update case record types via the Apex Dataloader.  As it turns out, the administrative account i was using on the dataloader did not have the target (new) record type assigned to it, and that's why the error was taking place.


Just something else to check.  The error is pretty generic, so cross-reference id seems like it could mean access to just about any ancilliary object.


Hope this helps!


I'm getting the same error when trying to update opportunity record types via Apex Dataloader. How did you fix this " target (new) record type"


I got it, go into my profile "system admin" and add those record types and then I can upload! Crazy, got it. Thanks so much for putting this nugget of informaiton out there or I would have never figured it out!

Christopher FederspielChristopher Federspiel
Racked my brain on this one for a while. I was trying to map an ID from an old org to a new one without using the Upsert field. I was using the regular field instead of the one that Dataloader makes for you when you specify the upsert... yeeeesshhh
I had this error when inserting campaign members from one org to a new org. Errors were thrown for any campaign members that were converted leads because a converted lead is read-only.
My solution was to sort the campaign members into 2 groups: those with converted leads and those whose leads were not converted. On the converted lead batch don't map the LeadId field when doing the insert.
Aniket Mathur 6Aniket Mathur 6

In Challenge 8 of "Lightning Experience Specialist" , I'm not able to add Records to the Adventure Package object. I have tried using Data Loader and DataLoader io and it gives me the same error -"ERROR: insufficient access rights on cross-reference id: 0037F00000hynMA".(Refer ScreenShot)
 User-added image

Aziz Ahmed 1Aziz Ahmed 1
Our org just recently started using Opportunity Record Types, it seems the only way to change existing Opportunity Record Types from null/Master to an actual record type is by using Data Loader but I was getting the "insufficient access rights on cross-reference id" errors as well when doing this. My batch size was 200 and of the 26K opportunities we had only one batch failed, no matter how many times I resubmit this batch. I then changed my batch size to 10 and tried again - this time there were only 10 errors (progress!). I then changed batch size to 1 and was then left with only 1 error.

This narrowed it down and I realized that this Opportunity was super weird and wasn't related to an Account, I also wasn't able assign it to an Account or delete it. So I forgot about it and moved on with my life.