function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Java runtime errors with command line Data Loader 14.0

I'm trying to run the Data Loader from the command line, and am running into problems.  First, I tried running it using as instructed in the Help & Training section.


C:\WINDOWS>java -jar DataLoader.jar
Unable to access jarfile DataLoader.jar


So, I tried specifying the full path.


C:\WINDOWS>java -jar "C:\Program Files\\Apex Data Loader 14.0\Data
Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-win32-3063 in
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at org.eclipse.swt.internal.Library.loadLibrary(
        at org.eclipse.swt.internal.win32.OS.<clinit>(
        at org.eclipse.swt.widgets.Widget.<clinit>(
        at com.salesforce.lexiloader.process.LexiLoaderRunner.main(LexiLoaderRun


Then, I tried to tell it where to find the library.


C:\WINDOWS>java -Djava.library.path="C:\Program Files\\Apex Data L
oader 14.0\" -jar "C:\Program Files\\Apex Data Loader 14.0\DataLoa
Exception in thread "main" java.lang.NoClassDefFoundError: Files\salesforce/com\
Caused by: java.lang.ClassNotFoundException: Files\\Apex
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: Files\\Apex.  Program will exit.


What the heck am I doing wrong?!