function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Blackberry Mobile Simulator

I have downloaded a Blackberry Mobile simulator (version: 8130-Verizon) from the Blackberry site and installed it in my machine. I have configured Blackberry MDS simulator to work behind a proxy. It is working fine. I have installed the Salesforce Mobile Application.
But after that whenever I am trying to configure the Salesforce Mobile application, I am getting struck in the screen showing: "Device info has been sent to and is awating registration".
 It is not proceeding any further. Any help?


Hi Srijan,

I am also trying to od the same, but no success as of now. I ahve downloaded blackberry simulator and installe dthe same. whenever i am trying to login in the simulator getting same message what you mentioned.

What is Blackberry MDS simulator and how it works with proxy. I am also trying this in corporate proxy env.

Your help very much appeciated. Thanks

I do realize this is somewhat too late, but I am trying to do the same thing and I cannot get past this message.

Were you able to fix this? And how?



I ran into similar problems.  I could not diagnose the problem at all and I assumed I was having a conflict of some sort.  For other reasons, I had to rebuild my machione and when I went back and intalled the simulator, it worked.  However I would still get hung up at this screen.  A simple exit/restart of the simulator would jump me to the next step

I have tried unsucessfully to connect the simulator to my Sandbox. I am working from a company firewall


I have tried the following:



Added the following info according to this site:

application.handler.http.proxyEnabled = true
application.handler.http.proxyHost = *.*.*.*

application.handler.http.proxyPort = *




My Username contains a '\'  and password contains " . Can any of this be a problem?


2) To connect to the sandbox i added

In the System info->Support Command->Enter LZSAND and Save



I have even uninstalled /restarted the machine and re- installed the simulator.

Can anyone help me to connect to salesforce via the simulator via a proxy.

Message Edited by sandyinmumbai on 07-16-2009 06:03 AM

Good for you Bryter.I uninstalled, re-installed, had IT look at the proxy settings,but no luck so far. I don't know what I could I try to do here to make it work.

David D.ax402David D.ax402

I am having the same problem, I had SF mobile working on a previous bberry model and recently got a Curve.  When I installed the SF mobile app on my Curve, I get the message "Device information has been sent to and is awaiting registration"


No clues from the app about how to resolve.

Same problem here.  Worked on my Sprint 8830 Worldphone.  Does not work on my new Verizon Storm2.  Anyone have any luck?

I have had this problem when activating my users.  From the main blackberry screen go into options/advanced options/applications/Salesforce Mobile.  Bring up menu and select edit permissions.  Make sure Connections and User Data are set to allow, bring up menu and select 'Set As defaults', bring up menu and select 'Apply defaults'.  What has happened for me is that the modules connections will not get the correct permissions when Salesforce is installed.




I have encountered the same issue as we roll out new bb and other mobile devices.  As a company we have new policy, we first check with sfdc to ensure they support the OS system on the new device before we even consider a purchase.  I can tell you the Storm2 had an OS sytem on it that was not supported by SFDC for mobile and unless you wiped the device and downgraded that OS it would not work. In addition, there are work arounds required with the Storms for SFDC mobile.


SFDC mobile is a great tool, but the IT group and users need to check SFDC documentation to ensure they are using a device and OS that is supported.


Can you change your device PIN and try this again??? I am hoping you have done all your configuration properly. If not or if you have any difficulty please let me know. I will try to help you out.


I have the same problem, simulator hangs on Registration screen. No idea what's happening! Any help would be appreciated.



ChikPea Inc


Hi all,


Though it is quite late with this thread, is there any solution for this problem ? I am also working with company firewall and my proxy is working fine. I am able to connect to internet via BB simulator, I downloaded the SF app but after that I am not able to register. I have tried connecting to both sandbox (lzsand) and production (lzprod).


I am using MDS simulator version  : 4.1.4


I have tried the setup with BB simulators 9300 (ver., BB9700 (ver.,  BB8300 (ver


Nothing seems to work and I am always stuck at the registeration screen in mobile.


Please help me out here.


Thanks & Regards,