function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Outbound Messaging: PermissionsDisableNotifications

I'm attempting to prototype some simple outbound messaging scenarios with my Sandbox instance. Looking at the API docs for Winter07, a note is made that

"To avoid an infinite loop of outbound messages that trigger changes that trigger more outbound messages, we recommend that you update objects with a user whose profile has the PermissionsDisableNotifications set to true"

Try as I have within AppEx Builder I can't find the particular option as an assignable value. Out of curiosity, I checked using SForceExplorer on the User object. Found similarly named permission flags for marking a user as offline or as an AvantGo user, but nothing that looked remotely related to OM. I also tried a cursory search on my live instance as well as on a dev instance with the same results.

I'm not gated by this and my end point to consume the outbound message isn't going to do anything of note, so the fear of an infinite loop of messaging is remote. However once we do prepare to roll live with this, this might be of greater concern, so knowing where to set this and adding it to our deploy checklist would be great... :P

Am I just blind and absolutely glossing over it somehow?
Its on the Profile object not the User object.
Ah! Are there any best practices regarding the creation of profiles for the specific purpose of assigning it to an outbound messenger? My searches are coming up w/ moderate amounts of info regarding specific development tasks for implementation but less so on the design, deployment, security perspectives.. Thanks though.



I found where these profiles are located.   You need to be logged in as a system administrator then:

1. Click your user name>> Setup
2. Administrative Setup>>Manage Users>>Profies
3. Create a new profile using the "System Administrator" as the Existing Profile
4. Now edit the profile, go to "Administrative Privledges" section and deselect "Send Outbound Messages"

Note: I also recomend setting the password to never change so that your 3rd party app doesn't lose credentials if you're statically logging in for the user.


Original Text:


I am using C# .net and have similar issues.  I can't seem to find where at in the system to set the user profile to prevent outbound messenging. Is this done in code or through the system preferences somewhere?