function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

is this a salesforce bug?


There are issues with the new Rich text area field which is available for the salesforce knowledge.

When I am trying to alter the field level security of a field which is rich text area it is not reflecting.

It is working in a wierd manner.



I have 2 fields rta1 and rta2 which are rich text area fields.

rta1 visible(true) read only(false)

rta2 visible(true) read only(true)


these are the settings for my custom profile which has both view and manage articles enabled.

When I go into the article management tab it is making both fields read only.


Its is happening when I am having multiple rich text area fields and when I mark one of them as readonly the remaining RTA fields are also not editable .



Please help me with this.

Going South.ax738Going South.ax738

Where are you setting readonly? if its via admin setup/security controls/field accessibility, pl check that when you make a field readonly, you make it only for the profile [on the top]  but not for pagelayout too.




This is a recently known issue we are working on at the moment.




Hi, Thanks for looking into this issue.

@ Going South: The page layout for article types looks like a minimal version of page layout available for normal objects. we cannot mark the fields as readonly from the layout. the only way to make the field read only is to change the field level security

Going South.ax738Going South.ax738

Ok. Here is what I did.


I created 2 rich text edit columns on custom object of 'test' and I set it up field security one for readonly[true] and other for readonly [false] but did not change setting for tab. I did get expected result of only one of them set as readonly. I swapped permissions and then only their readonly showed expected behavior.


The test object is public read/write and profile permissions for logged-in user is set for read/create/update/delete. but viewall and modiftall is unchecked.


result: The rich text edit controls are working fine as expected. Dunno what I am missing from your case.


yes, you can edit and set readonly setting from tab layout also. Go to your tab layout, click on edit and click on tool-icon on the top right corner of the rich text field which would give you a popup with two check boxes, and one of them is readonly. Make sure it is unchecked for both your rich text edit columns.


hi Going South,




Going South.ax738Going South.ax738

I am looking at help documentation and for article it says


"Field-level security doesn't prevent searching on the values in a field. To prevent users from searching and retrieving records that match a value in a field hidden by field-level security, contact Customer Support for assistance with setting up your organization to prevent unwanted access to those field values."


"If using both article-type layout and field-level security to define field visibility, the most restrictive field access setting always applies. For example, if a field is hidden in the article-type layout, but visible in the field-level security settings, the layout overrides security settings and the field won't be visible. Some user permissions on profiles override both page layouts and field-level security settings. For example, users with the “Edit Read Only Fields” permission can always edit read-only fields regardless of any other settings."


So, this is true for all columns not just rich text edit columns.


For permission setting you need to set it via Setup | Customize | Knowledge | Article Types | select field | Set Field-Level Security





@Going South :

Thanks for looking into the article settings.

the articletype layout is not giving me an option to mark any field as readonly.The only way for me to make a field readonly is to make the changes in field level security.


The profile settings except for system administrator no one has access to "edit read only fields" and the settings that are active for any other user are "view articles " and " manage articles" and the "knowledge user " enabled in user settings .



Going South.ax738Going South.ax738

For the individual users that are not admins, verify on their user level permissions [not profile] for Knowledge User checkbox to be checked.


On user profiles check on following:


  • Check on “Manage Salesforce Knowledge” user permission along with “Customize Application” checked. These permissions are on by default in the System Administrator profile.
  • Users who will find and view articles need the “View Articles” permission. This permission provides full access to the Articles tab. “View Articles” is on by default in all standard profiles.
  • Users who will create, edit, assign, publish, archive, or delete articles need the “Manage Articles” permission.


@ Going South :

thanks for looking into this issue. i found a scenario where sales force fails to save an article if the page layout has a read-only field at the end .

this does not effect the administrator.


example: i have 3 fields fl1,fl2,fl3

and if i mark fl3 as read only and keep that at bottom of the layout i am not able to save the article.

it shows an error like this :  articleEdit:createDocumentForm:sectionRepeat:0:fieldRepeat:0:fieldName: An error occurred when processing your submitted information.


now move the fl3 field to top of the layout , it works fine.