function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

IDE - Unable to create new ApexClass

This may be related to this post [], but the error is different so I thought a new post was appropriate.

I "upgraded" to API v14 from v13 and now when I try to create a new Apex class (or trigger for that matter) I get the following error:

Unable to create new ApexClass <Name of class> [unpackaged]

Reason: An unexpected error has occurred. Please try again, or check the log file for details.

Details: java.lang.NullPointerException

I've downgraded to v13 and am getting the same error. v13 had been working fine prior to the upgrade.

Any thoughts?
After upgrading to v14, did you delete and recreate all your projects? projects are not compatible/upgradable/downgradable between v13 and v14.

If your project has a folder "src/unpackaged/" then it is incompatible with v14.
I tried a couple of things:
  1. Deleted/recreated my project from its existing workspace. Result: same error
  2. Created a new workspace; created a new project. Result: same error
I'm going to try the upgrade on a colleagues machine.
I would recommend installing the latest IDE into a clean Eclipse 3.3.2 instance.  There is no direct upgrade from the v13 (developer preview) to v14 (GA) release.

Message Edited by JonP on 12-08-2008 02:24 PM
We've tried a bunch of different combinations (old and new version of API with clean Eclipse install with and without updates) with no luck.

I was able to reproduce the problem on a colleagues machine.

I'm going to open a support ticket for this.
What version of Eclipse and what OS are you using?  Do you have any other third party plug-ins installed?