function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Can't access sandbox from Eclipse - Problem with new security regime???

I was working in Eclipse this AM and did a successful deployment from sandbox to production. Then, when I tried again to save an edited class, I got an error saying that I couldn't log in. When I tried to refresh from the server I got this:

Here's what I don't understand:
  • I can log in to my sandbox via the web UI but not from Eclipse. If I'm doing this all from the same machine then my IP should be on the whitelist. Why does Eclipse fail?
  • This notice is telling me to reset my security token and use it in my login. Sandbox user accounts are set up automatically for you when you create your Sandbox. The user accounts are autogenerated with an email address of That's a clearly invalid email address. The only way I know to find out my security token is to reset it, which tries to send it to my email, which never comes to me because the email is invalid.
  • I can't change my email address on my sandbox account, becuase the only mechanism for that is to go through the email loop, which doesn't work
  • If I set up a new sandbox account with a valid email, I can log into the sandbox from the UI, but not from eclipse
  • If I regenerate my security token I still can't login from eclipse
I'm trying to fix some bugs in the sandbox apex and deploy to production but this is holding me up. I know the Eclipse toolkit is "not supported" but it appears to be broken in regard to sandbox use.


More info....

This appears to be related to the new security setup as the instance I'm having trouble with is on na5. I tested out a sandbox connected to an instance on na4 and I'm not having problems. That server hasn't gone to the new security setup yet.

I suspect there is a new eclipse plug-in on tap to deal with changes in the login aparatus. Can I get that now? I'm on deadline with a client who happens to be on na5...Help!

Hi Steve,

If you can login via the web UI, then you can change your email address.  When you change your email address, there are actually two separate emails that are sent.  One goes to the old email address as a notification that the address is being changed.  The other goes to the new email address for verification.

Once the email address is changed you should be able to use the token.  Unfortunately, I no longer am developing the Eclipse plugin so my visibility into the "why" it's not working is clouded.  I agree that the IP address should be the same regardless of which way you access the platform (api, or ui) and that may be a bug that requires additional investigation.

I'll see if I can't duplicate this.
Yes that worked. Thanks Dave and Ron!

  • go to the UI and change the email from to
  • get the email that the address has changed and click the verify link
  • go to the UI and generate a new security token
  • get that email and append that aRaEseAxO5NHliQWw78waNOk to the end of your password in the eclipse project
  • apply changes and it works!


HI there,
i'm having a similiar problem . . .i was asked for the first time to verify my ip address, did so, then added it on the network access sites in setup, but still can't access this same instance via the dataloader. i even went and redownloaded the data loader after i'd verified my address, but still no luck! can anyone help?! (i'm able to login to the instance via the login page so i don't see why i'd want to reset my securtiy token)
i got it! i checked out my user account, found all the failed IP addresses, and added that to my whitelist.
seems that from the dataloader, i was logging on via a different IP address than when i logged on to the website.