function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Trouble logging into apex data loader

When prompted by the apex data loader I enter my username and password, but this message keeps appearing:

Error logging in to Salesforce. Please check your username and password.

When I login to with the same username and password it works.

Does anyone know why I can't login to the data loader?

Message Edited by Lkc037 on 12-11-2007 11:49 AM
go to settings and check the server host of the apex data loader.
Try to set it up with for production and try.
Tom TobinTom Tobin
Try to do a password reset.
The data loader uses the API, so as the new API tokens are rolled out, you may have to reset the password to get the token, and use the token as the password to the data loader.
Thanks for the help, but unfortunately it did not work. The server host was already set as
Greg HGreg H just released some new security measures for instances when a user tries to login to Salesforce outside of a trusted network.  This would be when making API calls from an external server, using the Excel connector and using the Data Loader - among other tools.

You will need to reset your security token before following the instructions below.  To reset your security token click Setup > My Personal Information > Reset My Security Token.  Then click the "Reset Security Token" button on the resulting page.  After that you will receive an email with your security token and some instructions very similar to these...

How to enter your security token:

If your password = "mypassword"

And you security token = "XXXXXXXXXX"

You must enter "mypasswordXXXXXXXXXX" in place of your password

Remember that these security tokens are for tools like the data loader but not for use on the standard login page.

This is somewhat of a pain but unavoidable due to the recent phishing scams.

It worked, Thanks!!
I took a different approach that still worked. However the token method seems to be much easier. Essentially I  changed my sf password and re-installed Apex Data Loader. I am thinking that changing my password did something to authenticate my account from that specific IP. -Thanks to all for your help.

I'm having the same issue, but resetting my security token and following the steps to login with the token appended to my password doesn't get me past the login.


Anybody have any tips/tricks to get this **bleep** thing to work?

What does login history show ?

Simon -


Wow, quick reply - where do I find the login history?


Tim J.

In the web app, under setup / user management.
UsernameLogin TimeSource IPLogin TypeStatusBrowserPlatformApplicationClient VersionAPI TypeAPI Version
tjoyce@ingts.com8/6/2009 12:33:12 PM CDT65.113.255.62ApplicationSuccessFirefox 3.0WinXPBrowserN/AN/AN/A
tjoyce@ingts.com8/6/2009 12:23:32 PM CDT65.113.255.62Partner ProductPassword LockoutJava ( Loader16.0SOAP Partner16.0
tjoyce@ingts.com8/6/2009 12:23:28 PM CDT65.113.255.62Partner ProductPassword LockoutJava ( Loader16.0SOAP Partner16.0
tjoyce@ingts.com8/6/2009 12:20:48 PM CDT65.113.255.62Partner ProductPassword LockoutJava ( Loader16.0SOAP Partner16.0

Hi All,


has anyone got anymore info on this? I cant login - my logs are saying I am using an "invalid password", I have tried resetting my sec token also, and downloading/re-installing data loader.



Ric PalmerRic Palmer

This solution worked perfectly. Thanks.


Generally anything outside from salesforce using your password (like the data loader)


You'll want to do this:


"myPassword" and your security token is "XXXXXXX", you will enter "myPasswordXXXXXXX" into the password window.


I know you posted this years ago, but may I just say THANK YOU! I searched everywhere for such a seemingly simple answer and found nothing. This did the trick and laid it out in simple terms. Thank you, thank you, thank you.

Andrew MishlerAndrew Mishler
It's funny how a solution posted 7 years ago can still apply to today's version of SFDC and DataLoader. Thank you for the awesome help!!!
Nishant Dubey 7Nishant Dubey 7
@Greg H thanks :)
Nishant Dubey 7Nishant Dubey 7
Enter : Password+SecuirtyToken
One of the reasons you cannot login to Apex Data loader for a newly refreshed Sandbox is, instead of using the generic Server Host URL as https// use your instance name i.e. something like
Steps I followed:
1) Had another admin reset my pswd
2) reset my security token
3) logged into data loader using format 'password'+'XXXX' <--Security token

Worked perfectly.  Thanks.
Nishant Dubey 7Nishant Dubey 7
append security token in password like password+security token
Evgeniy CherkasovEvgeniy Cherkasov

Hello, I have a problem with connect on my developer's and test accounts.

I can't login through dataloader with following message:

«2015-12-28 23:12:06,563 ERROR [main] client.PartnerClient loginInternal ( - Error while logging in to web service at:, error was: Element {}returnFieldDataTypes invalid at this location Element {}returnFieldDataTypes invalid at this location

I use correct login and passwd+token and I add my public IP (Russia) to Trusted IP range on Network Access page. In my case my public IP are different with my real IP in local subnetwork.

At the same time I can login with the same login and passwd+token from our US office with US IP.

Can you help me with this?


Pradeep AithaPradeep Aitha
The error could happen if the ip address of the network is not whitelisted. go to Set up > Security controls > Network Access and add your Ip address to the list of networks and trying logging to Data Loader. 
Francys Curven 1Francys Curven 1
I have tried all of the above but i'm still having the issue.
I'm using trail head

Data Loader PAsswword IssueSalesForce User Logging
Remember to append your security token to the password you input
francys curvenfrancys curven
I have tried with and without appending the security toke4n. I get the same errorWith Security Key and still getting error.
Are you using your sandbox/dev login or your salesforce enterprise login?  Sanbox logins require your login + '.[Sandbox instance name]' be input as your username.  Also, check with your admin (if that's not you) to see if your account is locked from so many login attempts.  You can also verify that you're not locked out by logging into Salesforce through your web browser as usual.
francys curvenfrancys curven
I"m using my Trail head playground
francys curvenfrancys curven
I can log int to my account directly with user name and password.
I don't have experience with Trailhead, but try checking out this thread ( to see if that helps.  It seems that other people have had this issue when using an older version of Dataloader with the Trail head playground.
francys curvenfrancys curven
I'm on version 40.0.0
francys curvenfrancys curven
wrong password. Thanks for the help
Nice!  Glad you found a solution.
Nathan WylderNathan Wylder
After about an hour of trying to figure this out, I just tried the OAuth option and it worked. Save yourself the headache and frustration. Just sign in using the OAuth option! It actually works much quicker.
Rahul BhallaRahul Bhalla
None of the options worked for me, So ended up ising the OAuth option for login.
That works too i Guess....:)
Lucy MonkLucy Monk
Thanks team, I used your OAuth shortcut suggestion & it worked!