function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Eclipse auto-complete / code assistance not working?

I've been seeing this more and more, the auto-complete / code assistance system for APEX in the Eclipse IDE often dosn't work. Even when I try to force if (CTRL+SPACE) i just see an empty list rather then the properties and methods of the object I'm working on.


Any ideas? Or is this a known issue?

Going South.ax738Going South.ax738

Did a refresh from sever on all objects prior ro code edits work?


Yes. New project in fact. And I'm talking about objects and variables that I create in the IDE. If I define a String and then type that variable name followed by a period I'm used to seeing a list of the string methods. This is no longer happening. At least not with any regularity.


Sadly I don't recal a version of the IDE where the code completion worked with any kind of regularity. Maybe I'm typing too quick? :)


I thought the '09 builds worked better then this, but I could just be misremembering. Another bit of strange behavior I've been seeing is that when I save the editor is resetting to previous location in the code. Makes it kind of a pain to work on a specific codeblock when I have to refind it after each save.