+ Start a Discussion

Unable to connect to host name "www.salesforce.com" when create new Project in Force.com IDE

I am new Force.com. Today I have installed Force.com IDE. Then i try to Create a new Project in Force.com IDE as,


File>New>Force.com Project> Then new Force.com Project window opened.


In that i have entered Project Name,  User name , password (Force.com developer Edition credentials) , and select Environment as Production/Developer Edition.


Then if i click "Next"   Error displays like below,



Unable to connect to host name "www.salesforce.com"

Invalid username,password, security token or user locked out.....etc.....



Also I have tried by using my salesforce login details, that also same error occurs.....Also try to reset security token......no one working...........What is the problem here...............Plz help me...............

Ankit AroraAnkit Arora

You have to enter the security token also.


Goto : Setup > My Personal Information > Reset My Security Token > You will receive a security token in your mail.


Put that token with password and then try.



Ankit Arora

Blog | Facebook | Blog Page


Hi Ankit....I have tried that also....But it shows error as below,


    Force.com Projects require an organisation with the Metadata API Enabled.

    API is not Enable for this Organisation or Partner.


Plz help to resolve this.................




Where did you sign up for that org? It seems it is not a developer environment (or similar). I don't know of any way in which you can disable the metadata access. Try signing up here http://www.developerforce.com/events/regular/registration.php?d=70130000000EjHb




hey, would like to help, i got the same problem as him , i entered all the informations with the developer account and it doesn't work the same errors....they tell me that "Unable to connect to hostname "www.force.com" i need help please !!


I'm getting the same error.    Here's my relevant information:


Edition: Developer

Password: XXXX

Token (just reset): YYYY


At salesforce.com, I can login with XXXX

With the dataloader, I can login with XXXXYYYY


With the Force.com IDE, I have tried password XXXX and token YYYY, I've tried password XXXXYYYY and token YYYY.  Nothing's working.  What am I missing?

I have to same problem, please help
Goto : Setup > My Personal Information > Reset My Security Token > You will receive a security token in your mail.

User Id - "your user id"
Password - "your password"+"token from email" (of course w/o '+')

Mine worked this way.

teja kollateja kolla
Resolved: Issue with this error is while selecting the Org you should confirm that whether it is a Production/developer Org or Sandbox.

If you give Production/developer Org instead of Sandbox, you might get this error.
I have did quite a bit of research on this, and finally able to resolve.

This might happen due to a version mismatch of the force.com plugin installed on eclipse ide. try installing the previous api version of force.com ide. This resolved my issue.

Bhushan Mahajan 5Bhushan Mahajan 5

 you will use salesforce user name password & token. for login salesforce project.