function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Shai Ben-YehudaShai Ben-Yehuda 

Missing Organization Feature: Knowledge

I am a developer and we were trying to build an integration of LivePerson Agent within Salesforce. I could not install the Knowledge base app from, I got this error at the end of the installation: Package install error There are problems that prevent this package from being installed. Missing Organization Feature: Knowledge what does it mean? Do I need a license? thanks, shai

It sounds like you need the Knowledge feature license - when you go to Company Information do you see a "Knowledge User" row in the Feature Licenses section at the bottom of the page.  If not, I guess you need to contact your sales representative to get knowledge enabled.




That's correct, this package provice report & dashbaord leveraging salesforce knowlege product. It means that you need to have knowledge product activated.

Shai Ben-YehudaShai Ben-Yehuda

I guess have the license.


Feature Licenses


Feature TypeStatusTotal LicensesUsed LicensesRemaining Licenses

Knowledge User,  Active,  2                                       0                           2


any other idea?




You have the licenses, but it looks like they aren't assigned to any users.  Have you tried making the user you are trying to installed as a Knowledge user?  You do this via a checkbox on the user record.  Try re-installing once you've done that.

Shai Ben-YehudaShai Ben-Yehuda

thanks for the prompt reply.


I could not find the Knowledge user checkbox in the user record.


I got to the user record by:

administration setup -> Manage users -> Users ->Edit






That's rather odd - I have a Knowledge User checkbox above the Flow User checkbox.  I'm afraid I don't know what else to suggest - you have the same main license as me and the other settings look fine too.  I can't find anything in the help to suggest that Knoweldge User conflicts with any other user attributes (not that I've looked that hard TBH).


Out of curiosity, do you have Knowledge in the Setup -> Customize submenu?

Shai Ben-YehudaShai Ben-Yehuda

I opened this account around 2 years ago. Maybe it is related.


I'll try to open a completely new account. It means with new id and new email...


any idea how can I keep my email?





If you are using a dev org that has been created before November 2009, Knowledge cannot be available. Just recreate a new one and everything should be available.


I don't think the email has to be unique - I've used my email in a number of different dev orgs.


You can keep the same id too - just change your id on your existing dev org and use your preferred id to create your new instance.

Shai Ben-YehudaShai Ben-Yehuda



I made a new user:


In the colorful SF, I defined myself as a knowledge user


I installed again the package.


And was about to thank you all...


And guess what

I got the same error. Yet, in colors this time.

"Missing Organization Feature: Knowledge"


Just to remind me I got a warning before during the installation

This app does not list support for your edition of Salesforce. You can continue installation, but it may fail later in the process.








Can you send me your OrgId in a private message? that I havea look.




Looking at Francois' profile, he's SFDC so far better placed to assist than I am.


One last thing though - assuming you are creating developer orgs, I created one a couple of weeks ago and was able to install the exact same application that you are hitting issues with, so it must be possible!  I had gone through the knowledge setup and done a fair bit of configuration of it before I installed the package though, so it may just be one vital missing piece of config.


Good luck.


Just to add to Bob's answer, if you are using a developer org that was created before November 2009, then you are out of luck...


Just look at your org and the new one that you create have user knowledge preference that you can check. Once done, you need to setup Knowledge (create at least one article type) and you will be able to deploy the package.

Shai Ben-YehudaShai Ben-Yehuda

Hello Francois,


I think I did check the knowledge preference checkbox before. see


Did I check the right place?




Yes, that's correct, you check the right box. Did you also create at least one article type?

Prem ranjan 8Prem ranjan 8
1> you have to checked knowledge user in profile.
2> create at least one article type from customize>knowledge>article types.
3>checked this 'Yes, I understand the impact of enabling Salesforce Knowledge' customize>knowledge>settings.
now it fine.
Govind GovindGovind Govind
From Setup, click Manage Users | Users.
Click Edit next to your name.
Select the Knowledge User checkbox.
Click Save. ...
From Setup, type Knowledge into the Quick Find box.
Click Knowledge Settings.
Read the information on enabling Salesforce Knowledge in your org.