function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Why can't this Customer Portal User update this custom object?

I'm stumped on this one.  I've opened a case with Salesforce Customer Support, but also posting here in the hopes that someone from the User Community might have run into this.


Meet Professor Plum:



Professor Plum is entered in our system as a Person-Account, with access to the Customer Portal:




His profile setting is "Faculty Portal User", which has READ and EDIT permission on the Custom "Faculty Approval" object:




As you can see from this Detail Record view, Professor Plum is the owner of this Faculty Approval record:




Professor Plum needs to do a review of the student named "JP Seabury".  So he logs in to the Customer Portal and pulls up the Faculty Approval record:



Everything looks in order, so Professor Plum edits the record, rates the candidate, and then tries to save the record.


Oh no!  Professor Plum got an error message:




But how is this possible?  Professor Plum IS the record owner.  His user profile has permissions to EDIT this object, and even while the Sharing Rules are private for this object type (so Faculty Members can only see the Faculty Approval requests that have been assigned to them), when I look at the Sharing details for the record, it's confirmed that Professor Plum should be able to update this record:





I've checked and double checked:


1.) Profile has READ/EDIT privs of the Faculty_Approval__c custom object

2.) Customer Portal User is the record owner

3.) Custom object is viewable to customer portal users

4.) Sharing settings show full access for this customer portal user member.


What am I missing? 

Message Edited by JPSeabury on 05-17-2009 01:58 PM

My first tier Salesforce Support rep (Molly Johnson) worked diligently at this, but had to escalate it to her 2nd tier support organization.  It's been a week since the case was escalated, without progress.


In Molly's last voice mail message to me, she thought that maybe the reason the Customer Portal user wasn't able to save this record was because of the lookup relationship to the Student (a different account).  Even though the page layout defines that as a read only field, she thought that might be gumming up the works.


Going on that theory, I did the following in the Sandbox:

1.) Created a new Custom Object "Student Application". This object has only one custom field "Score". There is no lookup relationship to a Student (Person-Account) object, or anything complex about it.

2.) Created a new Student Application record.

3.) Assigned the record owner to our test Customer Portal User: Professor Plum.

4.) Verified that the sharing settings for this "Student Application" object were Public Read/Write. (That won't be the sharing model I use when we deploy, but for now I'm trying to open this up as wide as possible, just so I can get the Customer Portal user to be able to write to it.)

5.) Verified that the Customer Portal profile has CRUD access to the object.

I have the same problem as before: Professor Plum can view and edit the record, but as soon as he attempts to save the record, he gets an "Insufficient Privs" error response.



Does anyone have a configuration in which a Customer Portal user is able to Create / Update a Custom Object?  Can we connect and share notes?




No, I haven't found a solution, but while waiting for Customer Support to respond, I decided on a completely different approach.


I created a App user account, and tried to give them access to the same record.  The One App user was able to edit the record, but got the following error when saving the record:


Unable to Finish Processing Request
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Please indicate the URL of the page you were requesting as well as any other related information. We apologize for the inconvenience.

Thank you again for your patience and assistance. And thanks for using Salesforce!

Error ID: Data Not Available

I'm not sure that I've learned anything new, but I suspect the reason that the One App user and the Customer Portal User are unable to save this record is related.


Normal Enterprise Licensed Users (Admin and others) are able to update the record normally in the Sandbox. 


I now suspect this is a security permissions issue that I don't have influence over in the normal Sharing / Security setup, and that only Salesforce can help resolve.  Back to my waiting game.


JP, I have a CP running where CP users can sign in and add/edit/delete/view custom objects. Ironically the problem I'm having is giving access to STANDARD objects! (e.g. Contract object inexplicably is not available at all in the CP).


I was told originally that the Std CP user license did not provide access to custom objects, but I was using that license, and users DID have access. My experience is that SF can set up the CP in such a way that problems exist over which we have no control, there's obviously more config on the back-end than we can see.


FYI, my understanding is that ONLY the Customer Portal Manager Custom user license is meant to provide access to custom objects. But to me the fact that you can SEE the edit button, but cannot make an edit, suggests SF broke something, rather than you.



@ollie72 on twitter






I know its quite late to put a question related to this post, but my issue is - Why we can't update the 'Customer Portal Manager' profile's Std object permissions. For e.g. I need to give Create/Edit permission on Accounts and Contacts to this profile but when I edit it, I am unable to do same.


Any idea on this plz!!




In the end, this did prove to be a problem with stuff "behind the scenes", that I didn't have access to.  The ticket was escalated to Tier 3 Technical Support.  They found the problem and fixed it.  All is working well now (and has been for the past 6 months -- I had just forgotten about this thread until someone recently responded to it).