+ Start a Discussion
garybgaryb 

Can't deploy reports - "Dependent component, parent or metadata, is not deployable"

Hi all, been banging my head against a brick wall all day with this one!

 

I'm trying to deploy reports between two sandboxes using the Eclipse Force.com IDE - however, when selecting the components, the reports are greyed out with a "No Action" assigned to the. When you click on one, the message that appears is:

 

"Dependent component, parent or metadata, is not deployable"

 

To me this reads as if there's an unmet dependency somewhere - I welcome other ideas on this!

 

When I set up the project in Eclipse (using 15.0.2 of the plugin), I pulled in all the project's components using the "Manually select the components" option. I'm trying to deploy from the root src folder, so if there was a deployable component I could deploy to satisfy the dependency, I would imagine the report would appear as deployable. However, it stubbornly stays in the "No Action" state!

 

I'd welcome any solutions, ideas, or even just a simple "This is happening to me too!" just to keep me sane...

 

TIA!

 

garybgaryb
Suspect this may be because the source sandbox is on Summer 09 and the destination is not... Would appreciate confirmation if others are experiencing the same thing...
JonPJonP
If you just check the box anyway, does it work (or at least try to deploy it)?
garybgaryb
Unfortunately you can't deploy items with "No Action" against them - if no deployable components are selected, the buttons are greyed out preventing any deployment...
Rajesh ShahRajesh Shah

Try the following:

1. Try to migrate the whole Reports folder instead of the report. Maybe because the report folder doesnt exists in the other org, it is giving the error/

2. If your report uses a custom report type and if you are not migrating those, it might be giving the error.

3. Check the visibility of the reports folder. If it is private, then the report may not be migratable.

garybgaryb

Hi Rajesh, thanks for your response.

 

The folder already exists in the destination org and it's not set to private. Also, I've tried a deployment including all components, including report types and it's still appearing as No Action (I would expect it to appear as deployable but deploment would fail if I tried deploying the report without the report type).

 

Thanks for replying though, I'll see if your ideas can provide me with some inspiration...

Rajesh ShahRajesh Shah

hmmm.

 

Infact I am having a similar problem with Email Templates. I am trying to deploy  an Email Template but it too comes in grey even thoughit doesn't exists on the other org. Don't know whats the problem. 

Volker_factory42Volker_factory42

i also have Problems with reports. I can't chekc them out. They not included in Metadata. But I know it was working a time ago. So maybe this and Garyb's problem were causes by a Force.com IDE update?

 

Does anyone have an Idea how to get or migrate this reports?

Rajesh ShahRajesh Shah

I just tried a sample migration of report from one dev org to another and it was successful. 

 

Can you give the following information?

1. Report Name

2. Report Folder

3. Your Package.xml

 

This might help to understand why the reports are not coming in your metadata. Also the Force.com IDE I am using is 15.0.2

Message Edited by Rajesh Shah on 05-19-2009 04:49 PM
garybgaryb

Rajseh, I'll take a look at those thing and post back a bit later. In the meantime, I'm not sure if this is any help for your email problem?

 

http://community.salesforce.com/sforce/board/message?board.id=general_development&thread.id=29764

 

Gary

Volker_factory42Volker_factory42

I found my "bug". I still had Force.com IDE 15.01. So I upgraded, and everthing works fine!

 

Thanks!

MethosMethos

I've been having this problem as well.

 

15.0.2 on OSX

 

Trying on Windows now.

Message Edited by Methos on 05-19-2009 03:16 PM
MethosMethos

Just made a completely clean install of eclipse 3.3.2 and the latest sf plugin (15.0.2) on WinXP

 

pulled down my sandbox and prod projects...

 

try to deploy from sandbox to prod

 

same problem.

 

Note: I do not get this problem when deploying from one sandbox to another, only when trying to deploy to Production.

 

Note2: there are some items that it will allow me to try to deploy, but because of some test failures I can't actually even get them done.

MethosMethos
I'll try to post some more exact details later, but we solved this by setting up a workspace with an older version of the sf plugin and using that to deploy.  I believe there was some issue with a visual force page that the new plugin did not recognise.
garybgaryb

Stranger and stranger...

 

Other changes (objects, validation rules) were made in my source sandbox and I needed to deploy them as well, but they too were appearing as "No Action" with the same message.

 

However, right clicking and going to "deploy" on the parent folder of the component you wish to deploy (rather than the src folder) seems to get better results. Note that for objects, you right click on the Objects folder but for reports you seem to need to right click on the report folder, hence the "parent folder" comment above.

 

Does this bring any results for anyone else still experiencing similar problems?

 

TIA,

Gary

Volker_factory42Volker_factory42
Maybe you should try to create a new workspace and check it out again. I also had problems with package.xml and it was not possible to deploy different things. With a new workspace it was possible...
garybgaryb

I've checked the project out a number of times already, didn't seem to fix the problem. I thought about creating a new Eclipse install but have other things I need to get on with for now.

 

Thanks for everybody's help so far...

 

Gary

timmahtimmah

This definitely seems to be a Summer 09 issue. Everything I've been working on - classes, reports, standard objects, custom objects, etc - has the same thing: No Action in the checkbox column, and the message about not being deployable.

Tried a couple different versions of Eclipse/IDE and didn't help. Even deleted my project and recreated it in each.

 

 ARRRGGGHHHHH!

garybgaryb
timmah, have you tried my suggestion? If you right click a specific folder (e.g. "reports" or "objects") and try to deploy from there rather than from the root folder (i.e. "src"), are your components then available for deployment?