+ Start a Discussion
Santosh KumbarSantosh Kumbar 

Data loader CLI

Hi all,


I'm using data loader v22.0, for the Batch process of data. When i run through command line its giving error. Can some one suggest me which JRE version is need to run dataloaderv22.0?


Its urgent







What is the error you are getting?

Santosh KumbarSantosh Kumbar

Commanda i run: 

E:\salesforce.com\Apex Data Loader 22.0\bin>"E:\salesforce.com\Apex Data Loader22.0\_jvm\bin\java.exe"  -cp  "E:\salesforce.com\Apex Data Loader 22.0\SetUp\DataLoader.jar" -Dsalesforce.config.dir=E:\salesforce.com\Apex Data Loader 22.0\SetUp com.salesforce.dataloader.process.ProcessRunner process.name=csvAccountExtractProcess


Error i got:


Exception in thread "main" java.lang.NoClassDefFoundError: Data


Hi San


Please refer this link for DataLoader CLI,http://wiki.developerforce.com/index.php/Using_Data_Loader_from_the_command_line.

Are you specifying your Username and Password Correctly of your login?



Santosh KumbarSantosh Kumbar

Yeah....same process file if we run on my friend computer, it give succesfull result


Generate your password in the following way

1.encrypt.bat -g your(PasswordSecuritytoken).

2.Now encrypt that by encrypt.bat -e passwordsecuritytoken.

3.Now paste this encrypted pswd in sfdc.password.

4.And in sfdc.endpoint specify your (https://login.salesforce.com or https://test.salesforce.com).


I think it will help you.