function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Error with Eclipse, ANT and change set migration...solved

I had an issue doing deployment (sandbox to sandbox as a test):


Doing an Eclipse IDE deploy (as well as an ANT deploy) to a Developer Sandbox, getting the following error:

# Deploy Results:

   File Name:    objects/Account.object

   Full Name:  Account

   Action:  NO ACTION

   Result:  FAILED

   Problem: Custom Field Definition ID: bad value for restricted picklist field: RecordType


Tried deploying Objects on their own and tried disabling an Account filtered lookup I had (did not help).

Using Change sets gave different errors:

“Entity 'EmailMessage' not found.”


I DID NOT get this error via ANT/Eclipse...


I enabled the email to case service and change set deployed.


I can now also validate the eclipse migration.


I thought it would be helpful to anyone hitting the same/similar issue.  I've not used change sets besides 1 or 2 tests as I've seen an issue before, so have been reluctant, but may start.  I will use them to our test instance and if QA signs off on functionality, I will probably start.  They are sort of a pain, but probably can't be worse then getting ANT setup.

Best Answer chosen by Admin (Salesforce Developers) 

Can I mark this as solved?