function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Issue with log level on APEX Data Loader 27.0.1

I recently downloaded APEX Data Loader version 27.0.1. My colleague has a batch job that does a bulk upload of records to our salesforce account. I tried running the script on my computer and kept getting an error. I narrowed down the culprit to be the output of the command line when running encrypt.bat. 


When running the command line prompt "ecrypt.bat -g seed_text_here", the script is expecting the output to be just the key that should be saved to key.txt. This is consistent with the online video tutorial located here:


However, when I run "ecrypt.bat -g seed_text_here" on my computer, I get the following output: 

2013-04-24 15:06:21,050 INFO [main] security.EncryptionUtil main ( - encrypted_password_key_here


It appears to be an issue with setting the logging level. Any ideas on how to change this? 




Did you ever solve this? I am currently struggling with the log level of Java too. The output from encrypt.bat has to be parsed before it can be used anymore with Data Loader 28.0.2.


C:\Program Files (x86)\\Data Loader\bin>encrypt -g hello
2013-09-03 13:18:47,902 INFO  [main] security.EncryptionUtil main ( - 6b4ff6db4f2c2693

 It should be:

C:\Program Files (x86)\\Data Loader\bin>encrypt -g hello


Shri RajShri Raj


Did anyone of you got a solution for this? Please guide me since I'm facing the same problem.