+ Start a Discussion
Sunny GSunny G 

How to take The Data Backup in .csv or any other format with multiple languages in records



I have some users from Japan using same Salesforce application.And they use to enter the resords in their own japanees language only. Means that i have lots of data in Japanees Language also. But when i try to take the backup of the data using data loader. My Japanees data become unreadable something like "?????" . please suggest the way should i take the backup sucessfully with no data lost.

Best Answer chosen by Admin (Salesforce Developers) 

When records containing Japanese characters are exported using the DataLoader, they can sometimes display incorrectly in Excel. This is partly due to limitations within Excel itself, but the file can be set up to make it usable for import.

1) Open up the DataLoader and go to settings.
Make sure there are ticks in the boxes marked:

'Read all CSVs with UTF-8 encoding'
'Write all CSVs with UTF-8 encoding'

This will ensure support for the Japanese characters.

2) Make sure you have support for East Asian Languages.

To do this in windows XP, go to start, control panel, regional and language options.

Here you will see an option, about half way down the page, that says 'install files for East Asian languages'. This will need to be ticked, and the files installed. Your IT department may be needed to help do this.

3) Once the files are installed, it then appears that Excel has some difficulty reading Japanese characters in UTF 8 format.

However, you can be sure that the file is correct if you You open the .csv file in notepad.

When you do this, you should see the correct Japanese characters. However, it's much harder to work with.

You can then go to file, save as, 'Choose save type as 'all files', put the encoding as 'UTF 8', and then put in the file name with .csv at the end. E.g. Accounts.csv

Now you can try to open this up again in excel. The characters may still seem garbled, but in fact they are correct. If you were to import again, they should display correctly within Salesforce.

Please Note:
Because the file is saved in UTF 8, it's important that if you're using the DataLoader, you have the UTF8 boxes checked in the settings, if you're using the import wizards, you must use UTF 8 in the encoding selection.


Hope this helps.