function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Enrique DelgadoEnrique Delgado IDE Schema Explorer not showing standard objects added recently by

My Schema Explorer in the Eclipse-based IDE does not show me nor allows me to run queries that use newer standard objects such as FeedItem added in API version 21.0. 


I refreshed the schema, but that object is still not coming in, is there a way to update the schema explorer somehow? I'm viewing the schema of a sandbox. I wonder if the sandbox is locked to the API version that the production instance was at when the sandbox got created.


Any ideas?





have u tried eclipse 3.6.2(Eclipse Helios)?

Enrique DelgadoEnrique Delgado

Hmm, I'm using the IDE that has Eclipse built-in that you can download from:


So I'm trying to update it using these instructions:


Maybe that's what I need to do. I'll let you know. Thanks!



Enrique DelgadoEnrique Delgado

Well that didn't work :-/ Any ideas?

Enrique DelgadoEnrique Delgado

Community stumped? Didn;t think it would be that easy! Just trying to run a simple SOQL query using the standard object called FeedItem as found in the documentation here: