+ Start a Discussion

login to sandbox from Force.com IDE

Hi All,


I am trying to login to sandbox from Force.com IDE. I am getting the following error:


Unable to connect to hostname 'test.salesforce.com':
Invalid username, password, security token; or user locked out.
Please verify and/or change your credentials


When I entered Force.com IDE, I selected the environment "Sandbox" and gave the required credentials.


I could able to login from www.salesforce.com.


Coul anyone please help me to fix this? Your help is greatly appreciated.







Did you add sandbox name at the end of login name using dot convention




Thank you for your response. I did add . and sandbox name at the end.Still it is giving me the same error.


Reset your security token and try to login, I think it might work




Thank you for your suggestion.I did reset but no luck.


Do u mean r u getting error when u trying to login from Eclipse


Try to create new project by using same credentials. I think it should work.


After nearly pulling my hair out getting the same error message as Rima, I discovered I was making a super stupid/simple mistake:


In Apex Loader, you have to paste your security token in the password field, immediately following your password.  But, in Eclipse there is a separate field provided for the sercurity token.  Since my password was already saved in the Eclipse password field, all I needed to do was paste the security token I'd just reset into the security token field.  But, instead, I was typing my password and then pasting my token into the security token field.  I know, it makes no sense, but I was working fast and my habit of putting both in one field in the Apex Loader bit me. 


Hope that helps save somebody else a headache!

saleforce usersaleforce user

I had the same issue and the below is the right thing to do to fix this problem


Go to Admin User | Setup | My Personal Information | Reset security token


You wil be sent a security token to your e-mail


If your password = "mypassword"
And your security token = "XXXXXXXXXX"
You must enter "mypasswordXXXXXXXXXX" in place of your password



Thank you,


salesforce user




Thanks man. Evne I was doing the same mistake.

Radhika PawarRadhika Pawar
unable to connect to hostname 'www.salesforce.com' :
invalid username passwd ,secirity token or user locked out .
please verify and /or change your credentials.
please help me how i can do?
Julio DavilaJulio Davila
I have the same issue. 
Naresh RameshNaresh Ramesh
Login sandbox using browser, reset the security token in sandbox environment.
Paste the security token in force.com IDE  secutiry token field.

I tried this, it worked for me.