function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Cannot deploy profiles - no RecordType named idea.Record_type_for_community


I am trying to deploy profiles from sandbox to production. This is not possible because of the error message:



AProfileName : In field: recordType - no RecordType named idea.Record_type_for_community_091T00000004HfhIAE_entity_Idea found



I came to the conclusion that this is probably because the sandbox has a test community created (can be found in Customize -> Ideas - Communities). There is one default there named 'Internal Ideas' but in the sandbox there is an additional one.


I tried to de-activate the community. Then I removed the sandbox project from Eclipse and then imported it again (under a different name). Still the same error. Furthermore it is not possible to delete communities.


Now, what do I do? 


The idea has struck me to create a community manually in PROD but I don't think that it will have the same Id as the one in the error message above anyway.


Any help appreciated!


BR / Niklas


Hey Niklas,


Looks like you do not have the required recordtype on the 'Ideas' in production enviroment. you can the check the recordtypes : setup -> Customize -> Ideas -> Record type. It will list all the record types that are present in production.


If its absent in the production, you can either create a new record type there or deploy the refreshed idea.object file. Once the recordtype is available in production, try to deploy the profile again.


Or another alternative is the remove that tag from your *.profile file. But this would have to be done for all the profile files.




nickwick76, I am facing similar error
Problem: In field: recordType - no RecordType named Question.Record_type_for_community_09a30000000JJ5OAAW_entity_Question found

Did you find a solution for this?