function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

How to activate Customer Portal en Enterprise Edition


I tried to access the CustomerPortal in Enterprise Edition Org, but I can not see the option of Customer Portal, how active this option?


To enable the Customer Portal:

  1. Click Setup | Customize | Customer Portal | Settings.
  2. Click Edit.
  3. Select Enable Customer Portal.
  4. Click Save.

But I think in your case under "Customize" the "Customer Portal" link is missing. In order to make that link visible you need to file a case with salesforce through your org- requesting them to enable this feature for your org. Once that is enabled you will have the "Customer Portal" link under the "Customize" link.

Did this answer your question? If not, let me know what didn't work, or if so, please mark it solved.

I've struggled with this for a while, and searched the discussion boards and found nothing similar, so I've come to the conclusion that this must be a bug.
I have a commandButton that's part of a pageBlockButtons section:
<apex:commandButton action="{!saveAccountView}" value="Save View" rendered="{!AND(selectedViewId=null,NOT(selectedAccountId=null))}" />
That's the tag exactly as it appears on the page. The action method should navigate to a different page. Everything works fine if I remove the rendered attribute.  With the rendered attribute, the action method is never invoked, the page just refreshes. What's weird is that I have another commandButton on the page with pretty much the same rendered attribute and it works fine. I've tried changing the rendered attribute to:
<apex:commandButton action="{!saveAccountView}" value="Save View" rendered="{!showButon}" />
but that doens't work.
I've worked around this by using the style="visiblity:{!condition}", but I don't like this solution.


Is this option available for Developer Edition also? Who do I contact for activating it? I need it to test Facebook Integration.


Thanks in advance.