+ Start a Discussion
upNcommNupNcommN 

only java jre binary works

I have noticed problems when running applications with different versions of java.exe.  I can only get my software to run properly using the jre binary in j2sdk1.4.2_03\jre\bin\java.exe: if I try to use j2sdk1.4.2_03\bin\java.exe, or any of the jdk5.0 binaries, the login creates a RemoteException which is either a NullPointerException or a javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException:  No trusted certificate found.  Is this a known bug?  I need to know what's going on here to control deployment on different systems.

regards

aj

SuperfellSuperfell
Axis won't work properly on JDK5.0. the other problem sounds like a difference in the trusted certs being used.
Nikki.ax79Nikki.ax79
I haven't seen anything about jdk5 and axis not playing nice. Could you elaborate, or maybe provide a resource for this info? I'm about to upgrade my jdk but don't want to if axis won't work.

Thanks,
Nikki
SuperfellSuperfell
See the archives for the axis-user mailing listed on http://ws.apache.org/axis there are numerous reports of problems with axis w/ JDK5.0, and there are a number of bugs logged in the axis bug database for this.
Nikki.ax79Nikki.ax79
Thanks Simon!
upNcommNupNcommN

yeah i also downloaded the 1.4.1 sdk which is the version i'm currently deploying onto and both the sdk and jre binaries work fine, so whether the 1.4.2 sdk binary has a bug (the 1.4.2 jre works) or there's some kinda local problem on my dev machine i'm not sure.

aj