function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

ReportType is a valid field for reportaggregate in joined reports only

I am getting this error trying to deploy a few reports to our full sandbox. Anyone have any ideas as to what is going on?


BTW, the reports that are giving the error, are just basic reports, no joined reports, It is really just a report on Accounts with Opportunities


Can you open up a case with reproduction and post the case number here?



I find opening a case to not be a productive experience...


Anyone else having this issue?




We are having the same error when deploying reports from Sandbox to our production environment.

We have logged a case and still waiting for Salesforce reply.


Have you been able to find a solution ?





Solution was to build the reports in the org I needed them....


I am able to deploy joined reports but not others....


Let us know what support says...

Ven 777Ven 777

Even I got this same error on couple of reports and my guess is, I must have changed the type to Joined temparorily to try some options and then changed them back to Summary.


I used Eclipse to edit the .report xml file to remove the <reportType>Opportunity</reportType> tag inside the 

<aggregates> tag and saved it back to the sandbox before building the ChangeSet again. Which deployed without any errors.



Sorry for late reply, this issue was solved after some weeks.