function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Internal Server Error when uploading new managed package

Trying to upload a new managed package, this URL:


I get this error:


An internal server error has occurred
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience.

Thank you again for your patience and assistance. And thanks for using!

Error ID: 1929777022-196 (782432086)


Hello Haydn,


You would have to go to the dev org where package is created, recompile the class and save it. Create a new version of the package which should install fine. You would probably notice that this is because the "isvalid" checkbox of the class is unchecked.

Note : To aid backwards-compatibility, classes are stored with the version settings for a specified version of Apex and the API. If the Apex class references components, such as a custom object, in installed managed packages, the version settings for each managed package referenced by the class is saved too. Additionally, classes are stored with an isValid flag that is set to true as long as dependent metadata has not changed since the class was last compiled. If any changes are made to object names or fields that are used in the class, including superficial changes such as edits to an object or field description, or if changes are made to a class that calls this class, the isValid flag is set to false. When a trigger or Web service call invokes the class, the code is recompiled and the user is notified if there are any errors. If there are no errors, the isValid flag is reset to true.


Thanks for you answer vinita_SFDC, worked for me! :)

Austin Wang 5Austin Wang 5
Thank you! This also worked for me
Virath C. LiyanageVirath C. Liyanage
Yes, it has worked for me. Thanks!
Admin User 475Admin User 475
I cannot create a new managed package because I have already uploaded the package initially. I was able to successfully upload version 1.0-1.9. Only when I try to upload version 1.10 do I get this error. Is there another workaround? Support has referred me here.