+ Start a Discussion
DebbyDebby 

Read-Only Field is still Editable

Hi,

 

I have created a page layout and marked many fields read-only.

I then created a profile with both the "Edit Read Only Fields" and "Modify All Data" boxes unchecked.

 

However, when I logged in as that user, the fields are still editable for me.

 

Is there another setting that I am missing?

I even tried to set the field security to be read-only for all profiles; those fields remain editable.

 

Any help would be greatly appreciated!

 

Thanks,

-Debby

TrimbleAgTrimbleAg

Check the page layout assignments to make sure that is the page layout that the user is seeing.

 

PB

AroraAnupAroraAnup

Hi Debby,

 

Couple of things that you may want to check:

 

1. Are you testing this with a Sys Admin profile? Do take note that sys admins have Edit Read Only fields permission by default. So even if a field is Read only, an Admin with this permission would still be able to edit them.

2. If you are testing this with your new custom profile, you may want to double check that these permissions have been taken off or not

3. Page layout assignment - Since you have made the fields as Read Only at the page layout level, please check if you have the right page layout assigned to the profile that you are using to test this out

 

Hope this helps! Let me know how it goes.

sandeep@Salesforcesandeep@Salesforce

Now you have to assign this page layout to your created profile for this 

go to

Object schedma of your object -> Page layout Assignement - > Edit PAge layout Assignment-> now you can assign this page layout to created profile.

DebbyDebby

Thank for everyone's responses.

I had assigned the page layout, I just forgot to mention that.

I know it's reflecting the page layout because of the different sections I have created in the layout.

Any other ideas?

Thank you thank you. This is driving me crazy...

Kiran PandiyanKiran Pandiyan
@Debby Did you find the solution because I also face the same issue and I don't know why 
Li Zheng 10Li Zheng 10
Salesforce Classic:
1. Click on Setup | Manage Users | Profiles
2. Open the Profile for which the permission will be removed
3. Navigate to Profile | System permission
4. Deselect the option 'Edit Read Only Fields'
5. Save

retrieve from repository:
<userPermissions>
        <enabled>false</enabled>
        <name>EditReadonlyFields</name>
    </userPermissions>

refer to this link: https://help.salesforce.com/s/articleView?id=000335725&type=1