function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Problem in deploying Triggers from sand box to Production

Hello All,


I am trying to deploy a trigger from sand box to Production and I am getting "The changes you requested require to temporarily lock your organization's administration setup. However, the administration setup has already been locked by another change. Please wait for the previous action to finish, then try again later. (ALREADY_IN_PROCESS)"


I am getting this error from last friday, I am not sure this error is because of some admin changes in salesforce, or some problems in eclipse 3.5. After getting this error during trigger deployment I tried to deploy some classes the same error comes up.


I have also locked a case with salesforce on last friday but till now there is no reply, I tried to search for this on internet but I found nothing.


Please can any one help me in solving this issue.


Thanks & Regards

Vivek Manchanda

S P K.ax994S P K.ax994

Hi Vivek,


You face these type of problems when you are running test case and somebody doing changes related to code or admin








Thanks for your reply,  but I have checked no one is doing any type of code change and I am the only person who have the access to do any admin changes in the system.


I also try to create a new project in eclipse, but still the same errors are coming up.







When you create a project in eclipse please make sure the SFDC of prodution sould be logout.

If you keep open your SFDC in browser and try to create a project for the same environment then it will not be.





Did you find the solution?

I am facing teh same issue.





Hello Amit,


This issues only happens when you are trying to move something or trying to save some thing on production (Using Eclipse).


There can be many reasons for this issue, the major reason is when you try to save or move something to production and in middle process you stop it for doing or moving take longer time or evening due to some code coverage issues.


I will suggest you close your Eclipse or don't move or save anything to production for some time and it will automatically solve the issue.


Please let me know if it works.