function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Partner wsdl testing with Web Service explorer


I've generated a java client using Eclipse 3.4 and Axis 2-1.3 for the partner WSDL. I can bring up and see all the WSDL operations in a Web Services Explorer. 

I have a very basic question: when I invoke the login operation I keep getting this error. What am I doing wrong? I used the organization name and user/pwd I defined to access SalesForce developer edition

Thank you in advance

IWAB0383E Error validating {}Header LoginScopeHeader

The "LoginScopeHeader" is for the self Service user .


If you are a developer edition user , using partner wsdl , you don't need org ID ,for API login.

Your User Id and Password is required and make sure you are appending your security token with your password.


Thanks and Regards,

Dinesh Nasipuri



I tried with and without a orgId but I'm still getting the same error and I do use the token appended to the password. Any idea of what might be wrong? (note: I generated the java skeleton with axis2-1.3)



I looked at the SOAL response envelope and the faulty string is:


Please implement com.sforce.soap.partner.SforceServiceSkeleton#login


Now that makes sense. Does any one has a client sample code to share based on AXIs 2 1.x?



satish koletisatish koleti
Remove the header info  and check it...password should be password+securityToken

Satish K