function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Change Sets Error Message

Trouble with change sets:


1. Create change set in Full Copy sb, moving to Prod.

2. Upload set.

3. Set deploy fails because of missing field (in this case I forgot to add Record Types).

4. Go back to Sandbox, clone Change Set, Add Record Types.

5. Click Upload...get an error message:


Validation Errors While Saving Record(s) There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "Package member already exists". 


Uhhh...what? Why?


I deleted the old failed change set in production in case there was some channel conflict or something weird but that doens't help. Nothing I do resolves the issue. I'm forced to completely recreate the change set and hope for the best the second time around.


Anyone else see this?


By the way:

Using Chrome - when trying to 'remove' a component.. the removal happens except the FIRST component in the list of components is removed! not the component I was trying to remove!... logged in with Firefox and the removal mechanism works as expected. Argh. Bugs. : (



I'm having the same issue.

Uploading a cloned / altered change set i get "Package member already exists".

Recreating the change set with all the same contents works fine.


Any ideas?




The "cloning" of a failed change set wasn't doing the trick for me so I decided to clone the change set.. update it, and then I cloned THAT set a second time... only then was I able to avoid the issue. Sort of strange! Took a while to figure out the workaround. : (


Thanks for posting though, confirms something is weird. 




I have the same error after going back and cloning a change set, adding another component and trying to upload again.  I tried updating the clone change set and cloning it again and got the same error when trying to upload again.


I am also receiving that message.  Have to recreate change set from scratch in order to attempt another deployment.  Help!!


Ditto.  I went through the described cycle sucessfully twice, then the third time it died.  I cloned a 4th time just to get another changeset object, but it still won't work.


I think there is a bug with cloning of change sets and trying to upload them.  We have the same issue.  The only way we got it to work was recreate the whole change set again.  Below are the steps we did to test and validate:


  1. Created our first set (let's call it CS1), uploaded (success), then tried to validate change set to production.  Failed due to some missing fields.
  2. Cloned CS1, let's call it CS2, and added the new fields we missed.  Tried to upload, received "Package member already exists" error.
  3. Cloned CS2, let's call it CS3, and removed the fields we added.  Failed to upload
  4. Cloned CS2, let's call it CS4, which had all fields.  Failed to upload
  5. Cloned CS3, let's call it CS5, did a simpled edit of the package name did not change any fields.  Failed to upload
  6. Create new package with all fields.  Success in uploading.

Hope that help so this is why I think if the first change set doesn't work you need to recreate it.


I talked to support today and they said this is a recent known issue.  The fix in my case was to recreate the change set from scratch and add the components back, this worked for me.  my changeset is pretty small so mileage may varry.


The rep also mentioned that the other suggested solution was to use the ide to move the changes to production (circumvent the change set mechanism altogether), but I have no experience doing this.


This is a fairly serious problem when you have more than 200 items in the change set.  When will it be fixed?


I have more than 750 components in my change set and recreating the whole set sounds stupid.

Is there a fix already?


- VA


Response from my support rep:

"I appreciate your patience. It appears R&D has a tentative fix for this issue next week Wednesday [June 15th 2011]  evening. Please use the workaround for the interim.   I'll contact you next week with an update. Please let me know if you have any further questions."


Honestly I don't really believe him that he'll get back to me, they rarley do.  Therefore maybe check tomorrow, June 16th.


So.. I found a weird workaround that you can try:


If you get the error message clone the change set you had trouble with. Then, clone it once more and this time change the Change Set name. It seems making double copies basically clears some ID from somewhere..