+ Start a Discussion
BhuBhu 

Error while trying to use emailtocase.

I am trying to use emailtocase feature and I configured sdfcconfig.txt and email2case.txt. When I run the .bat , I get the following error. Any help is highly appreciated.
 
2008-06-20 13:15:16,162 110  [main] INFO  com.sforce.SalesforceAgent  - Attempting to start service com.sforce.mail.EmailService with configuration file D:\Bhu Folder\SFDC\RD\EmailCenter\EmailAgent\email2case.txt
2008-06-20 13:15:18,334 2282 [main] ERROR com.sforce.mail.GenericClient  - Failed to connect to SFDC service
com.sforce.ws.ConnectionException: Unexpected element. Parser was expecting element 'urn:partner.soap.sforce.com:accessibilityMode' but found 'urn:partner.soap.sforce.com:currencySymbol'
 at com.sforce.ws.bind.TypeMapper.verifyTag(TypeMapper.java:272)
 at com.sforce.ws.bind.TypeMapper.verifyElement(TypeMapper.java:294)
 at com.sforce.soap.partner.wsc80.GetUserInfoResult.loadFields(GetUserInfoResult.java:355)
 at com.sforce.soap.partner.wsc80.GetUserInfoResult.load(GetUserInfoResult.java:347)
 at com.sforce.ws.bind.TypeMapper.readSingle(TypeMapper.java:437)
 at com.sforce.ws.bind.TypeMapper.readObject(TypeMapper.java:362)
 at com.sforce.soap.partner.wsc80.LoginResult.loadFields(LoginResult.java:236)
 at com.sforce.soap.partner.wsc80.LoginResult.load(LoginResult.java:203)
 at com.sforce.ws.bind.TypeMapper.readSingle(TypeMapper.java:437)
 at com.sforce.ws.bind.TypeMapper.readObject(TypeMapper.java:362)
 at com.sforce.soap.partner.wsc80.LoginResponse_element.loadFields(LoginResponse_element.java:68)
 at com.sforce.soap.partner.wsc80.LoginResponse_element.load(LoginResponse_element.java:59)
 at com.sforce.ws.bind.TypeMapper.readSingle(TypeMapper.java:437)
 at com.sforce.ws.bind.TypeMapper.readObject(TypeMapper.java:362)
 at com.sforce.ws.transport.SoapConnection.bind(SoapConnection.java:119)
 at com.sforce.ws.transport.SoapConnection.receive(SoapConnection.java:93)
 at com.sforce.ws.transport.SoapConnection.send(SoapConnection.java:76)
 at com.sforce.soap.partner.wsc80.PartnerConnection.login(PartnerConnection.java:499)
 at com.sforce.mail.GenericClient.login(GenericClient.java:264)
 at com.sforce.mail.GenericClient.getConnection(GenericClient.java:178)
 at com.sforce.mail.GenericClient.<init>(GenericClient.java:134)
 at com.sforce.mail.ImapClient.<init>(ImapClient.java:40)
 at com.sforce.mail.EmailService.loadService(EmailService.java:153)
 at com.sforce.SalesforceAgent.main(SalesforceAgent.java:139)
 
TIA
cheenathcheenath
Check the API version of your endpoint. It seems you are using a different endpoint
version, that what the stub is generated from.

From the package prefix wsc80 it seems you should be using 8.0 endpoint.