function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Query timeout problem (Google App Engine)

Hi everybody,
I'm building an application on Google App Engine, using the web api. The application basically allows you to log in, query for some data and present it.
I started by using a developer salesforce account and all worked well: the login and the query.
But then I moved to a "real" salesforce account in a "real" environment.
I manage to login successfully, but when I query for data I get the following error: getContent: getContent: Timeout while fetching: 
I get this even if I narrow my query to a pretty small one.
Are there any timeout settings I should follow?
Is there any difference between a developer account and a "real" account that affects querying?
Thanks, Neuf. 
I get the same error.  I think it's a pretty simple query, just getting all Opportunities for a given User.  Did you find a solution?
Venkat PolisettVenkat Polisett


Google Appengine limits the urlFetch time to 5 seconds and that is causing this. We have posted a solution to this issue that will increase the deadline to 10secs (which is the max allowed by GAE) at sfdc-wsc website. Look at the following link:


Hope this helps.



Message Edited by Venkat Polisett on 12-11-2009 01:09 PM

Thanks for the tip, but it didn't work for me :-(


Tried adding this code: 


ConnectorConfig config = new ConnectorConfig();

config.setReadTimeout(10000); // 10 seconds

config.setConnectionTimeout(10000); // 10 seconds 


but I'm still getting the same timeout when I perform a query call.


Since it always works with my developing account and never works with a production account, I'm suspecting  some SForce settings or environment issues. I'm guessing GAE can't distinguish between the 2 accounts.


Any other ideas?