+ Start a Discussion
SamuSamu 

Link in lead email not working---

Hi All ,

 

  While creating a template in lead object the link is not working.

  Lead.Link

while using the template the link is populate in mail.

 

Can any one help me is highly appreciated.

 

 

Thanks

Samu

phiberoptikphiberoptik

Just to clarify, do you have a field on the Lead object called Link which contains a URL? And you are trying to include the Link field as a merge field on the template, with the expectation that it will display the URL in the template and be clickable?

SamuSamu
Hi Dear, For every object in template there is field called DetailLink if you select that sales force give you a option called copy and paste then u will find that {!Objectname .Link} after sending the emai u will get the link of the particular record Thanks Samu ______________________________________________________________________ Disclaimer:This email and any attachments are sent in strictest confidence for the sole use of the addressee and may contain legally privileged, confidential, and proprietary data. If you are not the intended recipient, please advise the sender by replying promptly to this email and then delete and destroy this email and any attachments without any further use, copying or forwarding
phiberoptikphiberoptik

So by Link, you mean Field Name? These are called merge fields. So for example, the field for the Lead's First Name is {!Lead.FirstName}.

 

What merge fields are you using in the template that are not populating? Please provide the specific ones.

SamuSamu

Yes , The field is {!Lead.Link} I m using .For that also i am creating a formula field but it is redirecting to the IE browser asking for credentials.

 

Thanks

Samu

 

 

 

 

phiberoptikphiberoptik

Sorry Samu, I still do not understand your question.

 

Do you have screenshots or can you better explain your current situation and what is occuring versus what you want to occur?

SamuSamu
Hi Dear, While creating a template in salesforce we can add some fields to send in our emailalert. Suppose I m talking about lead,If I am creating a template for lead object. Setup>Name>CommunicationTemplate>EmailTemplate>SelectTemplate Type>Then give mandatory fields> Then u can add like below:- Dear {!Lead.OwnerFullName}, A NEW Account has been created and the Lead has been updated with the following Account information: Click here to view the lead : {!Lead.lead_Link__c} --- LEAD ACCOUNT INFORMATION --- Account Name: {!Lead.Account__c} Account SBU: {!Lead.Account_SBU__c} Account Phone Number: {!Lead.Existing_Account_Phone__c} Account Fax Number: {!Lead.Account_Fax_Number_existingAccount__c} Account Address Line 1: {!Lead.Existing_Account_Address_line_1__c} Account Address Line 2: {!Lead.Account_Address_line_2_existingAccount__c} Account Address Line 3: {!Lead.Account_Address_line_3_existingAccount__c} City Name: {!Lead.City_Name_ExistingAccount__c} Account State Code: {!Lead.Account_State_Code_existingAccount__c} Account Postal Code: {!Lead.Account_Postal_Code_ExistingAccount__c} Country Name: {!Lead.Country_Name_ExistingAccount__c} Thank you, Salesforce Customer Team. The above link is not working.. Thanks Samu ______________________________________________________________________ Disclaimer:This email and any attachments are sent in strictest confidence for the sole use of the addressee and may contain legally privileged, confidential, and proprietary data. If you are not the intended recipient, please advise the sender by replying promptly to this email and then delete and destroy this email and any attachments without any further use, copying or forwarding
phiberoptikphiberoptik

None of the merge fields are working or just the {!Lead.lead_Link__c}?

SamuSamu

Hi Dear,

 

Can u please give me some solution how i can achieve this.

 

Thanks

Manoj

SabrentSabrent

Are you creating the  custom  lead_Link__c as a formula field becuase the standard {!Lead.lead_Link__c} isn't working?

 

can i ask what type of email template are you creating  --- Text, HTML, Custom or visualforce?

 

When you 'Send test and Verify merge fields' do you get an email?

 

I just created a email template  of type custom template in my org and had no issues.