+ Start a Discussion
ScotScot 

Triggering Workflow Rules: only works on the first update in a batch

I'm using batch update from Excel through the beta Toolkit, though I suspect that this may be an issue for any API usage...

It appears that when I issue a batch update (20 instances) which should trigger a workflow rule for each one, only the first is triggered. I've worked around the problem by updating one record at a time.


Specifics:
The workflow rule was on Opportunities, and the purpose of my update was specifically to trigger the rule for an already conforming record by alterning a field to make the test false, and then altering it back again. I tried several fields in the rule; all produced the same result.

My rule was:
    Has Items = 1
    Alert on Close <> No
    Stage contains Close
    Account: Area <> North America
    Account Division = ADT,Both

The instances initially tested TRUE. I altered the "Alert on Close" to "No" for a batch, and then altered them back to "Yes". The first rule performed for the first opportunity in the batch, but not for subsequent ones.

Scot