+ Start a Discussion
ScotScot 

Undocumented change in the API? or difference in the Toolkit?

I have noted a change in the behavior of the PriceBookEntry object. Before I modify my routines that do this ... is it a bug or an undocumented feature?  and is it expected to change back?

The last time I added instances to PriceBookEntry (through the connector, and thus the Office Edition Toolkit), the behaviors matched that documented for PriceBookEntry in the API documentation.

In particular,

UnitPrice
double
Unit price for this PricebookEntry object. You can specify a UnitPrice only if UseStandardPrice is set to False.

So, my code had a value for UnitPrice for the standard pricebook entries, but was empty for other pricebooks, where the UseStandardPrice was set to TRUE. I am virtually certain that I did this not because the documentation said to, but because it failed if I ignored it.

Today, when I ran the same update, the inserts failed, with a report that UnitPrice was a required field. Funny. I added UnitPrice, even for those records where it was not allowed, and everything worked.

Any idea what gives?

Scot