function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Classic ASP unicode character problem

I'm using the SOAP technique to read Sales Force data into a disconnected ADO recordset via "classic" ASP.  I'm having a problem any time apostrophes appear in the Sales Force source data.  If I view a problem record containing an apostrophe in a record in the Sales Force explorer it appears as some strange rectangle.  If I copy and paste that character into my code in an attempt to execute a "replace" I get errors in my development environment about converting the page to unicode.
Any ideas?  I'm sure I'm not the first person to have this problem but I haven't been able to find a resolution.
Thanks in advance.



Does anyone know if the connector tool works OK with Office 2007?

Any help is appreciated.


Any ideas?  I'm still scratching my head here . . .
Still begging for a solution . . .
I'm not clear on what the problem is. It sounds like you have an encoding mismatch. Is the problem putting the data into the recordset, what you do with it after then? by apostrophe, i'll assume you mean the word smart quote characters and not the regular asii apos character.
I apologize.  I'm sure I'm not explaining this clearly.  More detail:
I am reading Task object data into a classic ASP page.  I only display the first 50 characters of the task description.  The rest of the description is visible via a JavaScript hover method.  Some characters in the task description are causing major JavaScript problems.   
Example . . .
A task description looks like this in Sales Force:
Erin-- Can you change Justins opp back to me so I can filter him in my opportunity list.
When the full text of this description is passed to the JavaScript function, problems start occurring at the first line break before the "Thanks."  I have not been able to figure out what character(s) to escape so that it is JavaScript "friendly."  Other characters, such as apostrophes, appear to cause problems also.
Does this make any more sense?  Any ideas?
Thanks again.
Thanks, but nothing in that link helped.  I've tried escaping every possible problem character on the server and client side and nothing has solved my problem.  There is some bizarre character I can't account for in the example above when the data is read from Sales Force via the SOAP API.