function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

ASP / Office toolkit not working after move to Win2003

I have an application running fine under Win2k with the Office toolkit and classic ASP.  We're trying to move the app to a 2003 server and get the following error when a simple login test is run:

The code:

set sfApi = Server.CreateObject("SForceOfficeToolkit3.SForceSession3.1")
sfApi.SetServerUrl ""

result = sfApi.Login("--------","-------")

response.write "Login Result: " & result & "<br>"
response.write sfApi.ErrorMessage 

The output:

Login Result: False
Unable to send request to server. Access is denied.

Any help is appreciated.  Thanks.

Message Edited by stvjohnsn on 02-27-2008 04:38 PM

Message Edited by stvjohnsn on 02-27-2008 04:39 PM

Usually means the IIS user doesn't have perms needed to query out proxy info (used for auto detection of proxy settings).


Try changing the IIS user to be a "real" user first to see if it clears the error.  Last time i looked into this was a few years ago…


Sadly I can't find any of my old posts around this subject, but they should be here somewhere.

You can also turn on extended toolkit logging to see if there is any useful info.




add a string key: LogLevel value:1

add a string key:LogPath value: C:\toolkit logs\


Also, you can run debugview to see if that gives you any more detail (pretty sure it will).


If all that fails, post back here and we'll try a debug build.

Thanks foghorn,

I tried the 'real' user and got the same results.

I can't find HKEY_LOCAL_MACHINE\SOFTWARE\\OfficeToolkit within regedit and I have no idea how to run/use debugview.

Open for any and all suggestions.

Additional information: 

The SF servers actually see the login attempts as successful even though the toolkit reports it as failed.

I've also just tried on another Win2003 server with the same results.

Just tried an older version of the dll (3/17/2006) and received the following error, which seems to match some of the prior posts here:

Unable to send request to server. The requested lookup key was not found in any active activation context.

Message Edited by stvjohnsn on 02-28-2008 07:03 AM

Google debugview to get a good description of what it does and where to get it, but it is a tool that allows you to capture debug printlines from a running application.


Are you sure you set the IIS user correctly?

The actual IIS service needs to run as localservice.  It won't even start when setup to run as administrator.  So instead I set the application pool to run as a real user.  That didnt help though.

Ok, fair enough.

What I can do is send you v 4 of the toolkit, which runs fine in 2k3 server, under IIS6, under classic ASP (just checked).

Send me and email and I'll send you the dll.

V4 seems to have fixed it.  Thanks foghorn.
bill hayhowbill hayhow

Where can I get a copy of v4 of the Office Toolkit?  I'm still looking for a solution to this problem:

Bill Hayhow
Yes I too would very much like to obtain version 4??!!