function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Error: curl_exec error 28 SSL connection timeout on Win32

I am trying to setup to access SFDC webservices via PHP on a win32 based webserver.
I have successfully done this on a server running MAC OSX but when I use the login page from the SFDC php sample I get this error.

Error: curl_exec error 28 SSL connection timeout

Does anybody have a clue what I need to do to get SOAP/SFDCs SOAP calls working on PHP on win32?

I am having the same problem. I am running Windows XP with Service Pack 2. I am running IIS 5.1. I have a fresh install of php 4.3.9. I have the curl module enabled and the curl dll's moved into \windows\system32. I have loaded the SOAP modules via PEAR with all the dependencies.

I have added the line to disregard the HTTPS verification to SOAP\Transport\HTTP.php (after line 548, added "curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, 0 );"

But I cannot connect. I get the Error 28 - SSL connection timeout.

Any help would be greatly appreciated.


Update - I installed Apache 1.3.31 on my Windows XP, SP2 workstation.

In short, everything worked, with one small problem. The first time I try to login, I get the time out error. Afterwards, I am fine.

I examined the Windows SP2 Firewall. When Apache installed, it let itself be an exception and communicate with the outside world.

I tried to do the same with IIS (allowing the program c:\windows\system32\inetsvr\inetinfo.exe as an exception). Did not work. Also turned off the firewall completely. Still did not work.

Still very interested in if this will run with IIS.

Hi all,
Well, I don't specifically know what's going on, but I use curl quite a bit with SSL web sites.
I suspect there's something going on in your scripting, especially with session cookies being
accessed across multiple HTTP requests.

I don't mean to sound pedantic with this post, so bear with me if this info is obvious.
For one, try doing all your curl scripting by hand first, either in an X11 or cmd window; dunno
what your environment is, but I assume it's UNIX because you mentioned PHP.

This isn't a definitive list of things to try, but just things I have tried and worked.

1. Use the verbose option!
2. Write your cookies out to a file - especially when debugging.

curl -v -c cookies.txt -b cookies.txt -k \"\"

3. Write your output file to a text file.
4. Put all URL-options in the "-d" line, and NOT the site-specifier.


curl -v -o "/usr/home/me/testcurl.txt" \
-k "" \
-c cookies.txt -b cookies.txt \
-d "this1=that1\&this2=that2\&this3=that3"

I suspect you'll find a cookie or two for passing session data between your machine and the web server in question that is causing the problem you're describing.

Also, be sure you point curl to use the right SSL cert file... I doubt this is the problem or you'd never get as far as you have, but you might need to know how to do this if you call curl from a command line.

Hope some of this helps,


Message Edited by kevincar on 10-22-2004 03:03 PM